iPXE discussion forum
Wimboot WinPE - Printable Version

+- iPXE discussion forum (https://forum.ipxe.org)
+-- Forum: iPXE user forums (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: Wimboot WinPE (/showthread.php?tid=7582)

Wimboot WinPE - cwtaylor - 2015-01-08 17:00

Hi All,

In our network currently we have gPXE on a dhcp serve. We have been looking at moving our tftp server and upgrading to iPXE.

I have been testing this on virtualbox by chainloading from gPXE to iPXE and it has all been going fine.

I finally went to test this on a physical machine and it halts after "Entering bootmgr.exe with parapeters at 0x2a520".

I have now tried 3 physical machines and they all show the same. The linux distros we have are fully working however. I did try booting iPXE off a USB and this worked with both Windows and Linux.

This is the .ipxe script I am using for the PE.


kernel wimboot gui
initrd boot/BCD BCD
initrd boot/boot.sdi boot.sdi
initrd sources/boot.wim boot.wim

I am hoping that this is just a gPXE issue and if we tell our DHCP servers to use iPXE straight it should work OK. Just wanted to see if anyone had any other suggestions.

RE: Wimboot WinPE - robinsmidsrod - 2015-03-09 12:24

If you are currently using gPXE and are upgrading to iPXE you should ensure that you're using ipxe.pxe, not undionly.kpxe. If you're using undionly.kpxe then the driver from gPXE will be using during chainloading. You shoud also ensure you use the latest version of both ipxe and wimboot, as there has been some changes to some core interrupt-related code in the last few months.