iPXE discussion forum
(solved)Made an ISO,but can't use it. - Printable Version

+- iPXE discussion forum (https://forum.ipxe.org)
+-- Forum: iPXE user forums (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: (solved)Made an ISO,but can't use it. (/showthread.php?tid=7593)

(solved)Made an ISO,but can't use it. - danny - 2015-01-21 07:51

Dear all:
I built an ISO in CentOS 6.5_x86_64,and IPXE version is "commit d38bac05e7d0eb67fc19f3532a6b4fa00804106e".
1,git clone git://git.ipxe.org/ipxe.git
2,enable IMAGE_COMBOOT in src/config/general.h
3,created a basic.ipxe
4,execute "make bin/ipxe.iso EMBED=basic.ipxe"
i got the results:
genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !
rm bin/ipxe.lkrn.zbin bin/version.ipxe.lkrn.o bin/ipxe.lkrn.bin bin/ipxe.lkrn.zinfo

file bin/ipxe.iso
bin/ipxe.iso: ISO 9660 CD-ROM filesystem data 'iPXE '

ls -al bin/ipxe.iso
-rw-r--r-- 1 root root 34816 1月 21 14:45 bin/ipxe.iso

mount -o loop bin/ipxe.iso /mnt

mount: wrong fs type, bad option, bad superblock on /dev/loop0,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

i can't use this ISO,pls help me,Big Grin

RE: Made an ISO,but can't use it. - robinsmidsrod - 2015-01-22 09:01

Install the syslinux packages and the other dependencies mentioned on http://ipxe.org/download using your package manager and try to compile again. If it still doesn't work, make sure that the locations of isolinux.bin (check the makefiles) matches on your installation.

RE: Made an ISO,but can't use it. - danny - 2015-01-23 03:03

Thx robinsmidsrod, now i can make an ISO.