iPXE discussion forum
ipxe on intel i210-at - Printable Version

+- iPXE discussion forum (https://forum.ipxe.org)
+-- Forum: iPXE user forums (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: ipxe on intel i210-at (/showthread.php?tid=7739)

ipxe on intel i210-at - jomy - 2015-06-05 10:10

I am trying to get ipxe on the option ROM of an intel i210-AT NIC. Buillding the ipxe image does not seem to be a problem, but flashing the option ROM is trickier.

I have tried the following tools and concluded

flashrom : no support
bootutil.exe : no support
lanconf.exe : only support for read write of entire image, including all or most firmware, not just option ROM

remaining option seems to be backwards engineering the image read with lanconf, but I'd rather not go there.

Anyone tried and succeeded in ipxe:ing the i210 ? if so how did you do it?

I have posted a thread at intel concerning this, google "ipxe i210-at" if you are interested


RE: ipxe on intel i210-at - robinsmidsrod - 2016-10-07 09:47

Did you try to just build ipxe.usb and boot that to verify the hardware works? If that works then you should build bin/VVVVDDD.rom and flash that. If your NIC is onboard then you need to flash the motherboard, with a modified firmware for the motherboard. That is not recommended, and can easily cause your motherboard to be bricked. Unless you're experienced with these things I would recommend you PXE boot from a tiny usb stick with ipxe.usb instead of flashing the motherboard.