iPXE discussion forum
Anyone iPXE booting Windows10 ? - Printable Version

+- iPXE discussion forum (https://forum.ipxe.org)
+-- Forum: iPXE user forums (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: Anyone iPXE booting Windows10 ? (/showthread.php?tid=7820)

Anyone iPXE booting Windows10 ? - 16again - 2015-09-28 18:26

Over here, doesn't work:

WinPE environment sees iSCSI target to install to. Install goes fine....until install needs to reboot. On reboot, iPXE part of booting goes fine, windows boot loader is started....but runs into an inaccesible boot device.

afaik, during boot process the system loads registry settings and boot-time drivers, and then re-mounts C:\ drive using disk driver and settings from registry. I assume that's the failing stage, resulting in an inaccessible both device.

Tried both W10Pro and W10Ent, same result.

W8.1 Windows server 2012R2 and even server2016 Preview3 all iPXE boot fine.

Hints & tips welcome

RE: Anyone iPXE booting Windows10 ? - jkbrowne - 2015-09-30 15:39

I'm having the exact same problem. Windows 10 installs fine. On first boot after setup completes my network LEDs go dark and after many minutes I eventually get an INACCESSIBLE_BOOT_DEVICE error.

RE: Anyone iPXE booting Windows10 ? - mmeyer - 2015-11-24 01:29

I'm having the same issue. Every other version of Windows boots fine, including server 2016.

By chance, has anyone here found a solution (other than installing to a hard drive first and cloning that)?

RE: Anyone iPXE booting Windows10 ? - Tribble - 2015-12-12 11:13

Haven't done win10 deploys yet. Wrestling with secure boot from win10 certified hardware. Its secure boot only on those suckers :-(

but.. What I've found with GPT and EFI, and windows 10 repartitioning may be a help so I'll share it here. Good luck.

INACCESSIBLE_BOOT_DEVICE is typical from invalid settings in the BCD. However you may also get something similar from the EFI boot.
I use linux to clone partitions resize them etc. partclone.ntfsreloc is my good friend. But windows 10 this didnt work. Why? EFI, GPT an Windows Boot Loader.

EFI requires a special partition to find all the files in. This was easy. I thought the partitions GUIDs were easy too. WRONG!
Windows allows you to easily change the GUIDs THESE ARE PARTITION NAMES not the actual partition GUIDs. It was only when I dug deeper into each partition with the linux gdisk tool that I found DIFFERING partition GUIDS!

Now the trick is that while windows doesn't seem to use these partion GUIDs, Windows Boot Loader DOES!!! If I remember it correctly the GUID for the EFI partition is not critical, but the one for the system partition is.

Hope this helps


But the thing that really caused me problems was that UEFI requires GPT partitions with unique GUIDs.
Where I thought I was setting the GUID's within windows for the partitions, I was only setting DISKLABELS. It was only when I used the linux gdisk command and specificly dug into the partition for its GPT GUID I found a different set of GUIDs. It looks like the Windows Boot Manager looks for a specific PARTITION BASED GUID not the GUID DISK LABEL.

Windows does this with disk labels. I use a linux based tool gdisk to go past the disklabels and dig deeper and see the true partition GUID. Whilst windows doesn't seem to care about the partition GUID's it is ESSENTIAL to get them right for identifying the boot volume.

RE: Anyone iPXE booting Windows10 ? - biatche - 2016-03-17 18:51

Anybody found a solution to this yet? Install to hard disk and then clone don't work for me i dont know how u guys do it. (preparing automatic repair.. message)