iPXE discussion forum
Synology iSCSI Disconnect Issues - Printable Version

+- iPXE discussion forum (https://forum.ipxe.org)
+-- Forum: iPXE user forums (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: Synology iSCSI Disconnect Issues (/showthread.php?tid=7900)

Synology iSCSI Disconnect Issues - ukjamesh - 2016-01-02 15:10

Hi all,

I'm in need of some help Dodgy

Over the last few days I've been trying to get iPXE connect to my Synology iSCSI target with little success. I want to do this so I can boot from SAN ESX in my lab.

So far I've configured the following...

Added DHCP options for undionly.kpxe to boot from tftp.
Embedded a script in undionly.pkxe to load a script from http.
The script contains the following

sanboot -k iscsi: || chain

Created pxelinux.cfg/default to point at a menu for the ESXi installation via http if sanboot fails.

When I attempt to boot a diskless host(VM in workstation at the moment) I see iPXE load and then the ESX installation starts. Which is all good but I dont get presented with an iSCSI lun to install into... Sad
I've looked at the iSCSI logs on the target I see Login, which is then followed by Close about 15 seconds later...

So at this point I'm not sure if the issue is with iPXE or the target. So I built a freenas iscsi target and I was seeing the same issue.

I've tried to make it was simple as possible by booting onto the ipxe.iso and running the following

sanhook iscsi:

which responds with

Registered SAN device 0x80

but I still see the disconnect on the iSCSI Synology server about 5 - 15 seconds after.

I even tried a Freenas iscsi target and in the logs it gives me this
freenas WARNING: (iqn.initiator.com): no ping reply (NOP-Out) after 5 seconds; dropping connection

Anyone got any ideas? Should what I'm trying to do work?



RE: Synology iSCSI Disconnect Issues - birotokmag - 2016-01-12 18:31

The same happens here. I use RS815+. The wierd thing is I could boot WinPE but after installation I can't boot Win7.

RE: Synology iSCSI Disconnect Issues - birotokmag - 2016-01-17 13:13

For me the two things solved the problem:
- turn on the multiple I/O
- on the server give read and write rights for the booting client to the iSCSI target

RE: Synology iSCSI Disconnect Issues - MultimediaMan - 2016-01-18 07:52

Quote: Your code
sanboot -k iscsi: || chain

Couple of (Possible) problems here I can see - my example doesn't use pxelinux.0:


sanboot --drive 0x80 iscsi: ||

sanhook --drive 0x80 iscsi: ||
sanboot --drive 0x81 --no-describe$esxi5orlater.iso ||