Search Results
Post Author Forum Replies Views Posted [asc]
  Thread: Wimboot specifying wim index not working in version 2.7.4
Post: RE: Wimboot specifying wim index not working in ve...

Forum is closed, use GitHub discussions.
NiKiZe General 1 143 2023-01-20, 07:06
  Thread: Intel I350 with AlmaLinux9/Grub2 Network Issue
Post: RE: Intel I350 with AlmaLinux9/Grub2 Network Issue

The forum is closed, please use Discussions on GitHub instead. Be sure to include output from ifstat after running dhcp, Try latest version of iPXE which has fixes for vlans. snponly.efi should defin...
NiKiZe General 1 124 2023-01-18, 23:15
  Thread: Can I boot a from a BIOS PXE server on a machine that is UEFI PXE only
Post: RE: Can I boot a from a BIOS PXE server on a machi...

No, EFI firmware and PCBIOS is different platforms and you can not boot one from the other (except for a few buggy implementation) But running PXE binaries from iPXE in efi mode is not possible regar...
NiKiZe General 1 1,174 2022-06-28, 06:02
  Thread: Boot into TrueNAS installer via iPXE
Post: RE: Boot into TrueNAS installer via iPXE

Please note that this forum is not active any more, use GitHub discussions instead. (Closing this) You probably need to ask the dist on how to do the squashfs fetch, it might not be supported. And yo...
NiKiZe General 1 1,106 2022-05-22, 13:28
  Thread: Can't load EFI file in iPXE that works fine in the BIOS EFI Shell
Post: RE: Can't load EFI file in iPXE that works fine in...

Since this was also posted on GitHub discussions, let's keep it there https://github.com/ipxe/ipxe/discussions/550 Forum should really not be used: https://forum.ipxe.org/showthread.php?tid=32084
NiKiZe General 1 2,262 2022-01-12, 20:30
  Thread: iso efi boot with memdisk
Post: RE: iso efi boot with memdisk

Unlikely to get it working this way. This is mentioned in the FAQ. For the old Gentoo based sysrcd I provided a patch that made it easier to PXE boot.
NiKiZe General 1 3,379 2021-05-08, 09:35
  Thread: Running script to download image
Post: RE: Running script to download image

chain does download curl does not run in iPXE You could have iPXE call a http server, which does the download. but you should be fine just fetching the rawdata url of github.
NiKiZe General 1 3,164 2021-03-10, 16:08
  Thread: Problem install Windows 10 to iSCSI target
Post: RE: Problem install Windows 10 to iSCSI target

Most likely your nic driver
NiKiZe General 7 12,861 2020-06-15, 12:34
  Thread: get DHCP/Option#67 inside a script
Post: RE: get DHCP/Option#67 inside a script

Did you try config command? Hint there is platform containing pcbios or efi
NiKiZe General 4 5,909 2020-05-14, 19:54
  Thread: MemTest86 UEFI not sending reports to TFTP when Started By iPXE
Post: RE: MemTest86 UEFI not sending reports to TFTP whe...

You probably need to figure out what memtest are using in terms of efi calls and then try to debug that, but hey, why not contact memtest about it? are you using ipxe.efi or snponly.efi and have you ...
NiKiZe General 4 6,083 2020-05-14, 15:30
  Thread: Stuck on initialising devices
Post: RE: Stuck on initialising devices

Another thing that you probably should try is, first of course to make sure you are using the latest version of iPXE. But you should also try to boot it directly from a USB stick, both grub and syslin...
NiKiZe General 4 5,789 2020-05-14, 15:26
  Thread: iPXE on win10 1909 and hyperV
Post: RE: iPXE on win10 1909 and hyperV

Gen2 is efi, make sure that you build the efi binary and then put it on a usb device manually at first, and then go from there.
NiKiZe General 2 4,593 2020-05-14, 05:53
  Thread: Increasing HTTPS security on FOG
Post: RE: Increasing HTTPS security on FOG

I recommend that you take a look at existing messages at the mailing list, and also github pullrequests. Simply, iPXE do not have the latest SSL features.
NiKiZe General 1 3,255 2020-05-14, 05:51
  Thread: Stuck on initialising devices
Post: RE: Stuck on initialising devices

output of lspci -nn (linux command) Grab all lines that has "Ethernet" on them, or just take the whole bunch so that we can see your PCI layout.
NiKiZe General 4 5,789 2020-05-14, 05:50
  Thread: EFI + IPXE woes
Post: RE: EFI + IPXE woes

is secure boot disabled? Have you made sure that your setup are correctly configured to handle the efi network boot scenario (especially sending the correct binary) You should verify your setup with ...
NiKiZe General 2 4,242 2020-05-14, 05:48
  Thread: Mac mini with Broadcom BCM57766/BCM57762 : link status down
Post: RE: Mac mini with Broadcom BCM57766/BCM57762 : lin...

To me this seems to be the same problem, so you should write in the existing thread. What are you using when you boot from USB? a, ipxe.iso - which is pure legacy code. not efi. Reason for not worki...
NiKiZe General 2 5,763 2020-05-14, 05:46
  Thread: get DHCP/Option#67 inside a script
Post: RE: get DHCP/Option#67 inside a script

what about ${67} or ${filename} also run the config command and see what pop up
NiKiZe General 4 5,909 2020-05-14, 04:27
  Thread: Realtek 2.5G bps NIC(8125 chipset)
Post: RE: Realtek 2.5G bps NIC(8125 chipset)

Probably not, Linux drivers and iPXE drivers are not the same, even if some have been ported from Linux. However the best approach is to write them from scratch based on dataseheets. Suggestion is to...
NiKiZe General 1 3,618 2020-05-06, 04:24
  Thread: Setting console picture breaks the display when Ubuntu boots into kernel
Post: RE: Setting console picture breaks the display whe...

Not sure why you would boot an iso, but what is the actual error you are seeing?
NiKiZe General 2 4,382 2020-05-06, 04:20
  Thread: ISO build - Not taking config options
Post: RE: ISO build - Not taking config options

in one case you are building an efi binary, in the other a pcbios image, are you sure it is actually booting the correct thing and not something else? Also images not visible.
NiKiZe General 2 4,337 2020-05-06, 04:19