Search Results
Post Author Forum Replies Views Posted [asc]
  Thread: Boot issue on Lenovo 300e
Post: Boot issue on Lenovo 300e

We are working on trying to figure out why iPXE is not able to properly chainload the Linux kernel on Lenovo 300e devices. PXE booting into iPXE workes great and downloading the kernel and initrd bina...
SebastianRoth General 1 2,695 2019-11-06, 20:32
  Thread: Initial Make Error
Post: RE: Initial Make Error

Try installing package: Code: libstdc++-7-dev If that doesn't help you might want to search for other possible packages like this:https://packages.debian.org/search?searchon=contents&keywords=st...
SebastianRoth General 1 2,714 2019-11-06, 20:24
  Thread: Hang on "... free base memory after PXE unload"
Post: Hang on "... free base memory after PXE unload"

Hi iPXE-team, within the FOG Project we have played with iPXE a lot but this is the first time I think I have ever seen a picture of a client hanging on the message "... free base memory after PXE un...
SebastianRoth General 1 3,175 2019-08-05, 15:57
  Thread: [tls] received overlength Handshake - GoDaddy certs
Post: [tls] received overlength Handshake - GoDaddy cert...

Hey, we are using iPXE to chainload from HTTPS which works fine in most cases but fails with GoDaddy certificates. Steps to reproduce: clone latest ipxe git repo enable DOWNLOAD_PROTO_HTTPS in gener...
SebastianRoth General 2 6,818 2018-12-14, 15:33
  Thread: iPXE on DELL 7010 in UEFI mode
Post: RE: iPXE on DELL 7010 in UEFI mode

I got hooked up to this issue again as it is still a problem with most current iPXE in UEFI mode on the Dell 7010's and people start to move over from legacy BIOS to UEFI on those machines. So we are...
SebastianRoth General 6 21,708 2017-11-10, 07:20
  Thread: Exit SANBOOT hangs on latest Windows 10 build 1703
Post: Exit SANBOOT hangs on latest Windows 10 build 1703

We're seeing an issue with the exit to hard drive on Windows 10 build 1703. We recently updated to Windows 10 1703 in a lab, which were configured to boot to PXE by default. After the update, the comp...
SebastianRoth General 0 4,591 2017-08-10, 23:40
  Thread: Failed to restart TFTP issue
Post: RE: Failed to restart TFTP issue

(2017-07-24 03:29)richard_chen Wrote:  SebastianRoth, thanks for your reply, I'm sorry to say nothing about the quantity of DHCP&IPXE, we found if there only have one DHCP server, it can boo...
SebastianRoth General 7 17,075 2017-07-26, 11:43
  Thread: ipxe.efi with embedded scirpt hangs, precompiled ipxe.iso works, compilation errors
Post: RE: ipxe.efi with embedded scirpt hangs, precompil...

Hello Kamil, might this be related you think? (2017-02-22 11:55)kmwil Wrote:  Also, I cannot compile with all flags: I get errors like this: Code: [LD] bin-x86_64-efi/tg3.efi.tmp bin-x86_64-e...
SebastianRoth General 1 6,127 2017-07-23, 15:09
  Thread: Failed to restart TFTP issue
Post: RE: Failed to restart TFTP issue

(2017-07-18 09:30)richard_chen Wrote:  3. Condition for issue happend --------------------------------------------------------------------------- 1) there lots of NB in network, if there have 1...
SebastianRoth General 7 17,075 2017-07-22, 13:14
  Thread: iMAC with Broadcom 14e4-1686 BCM57766 : link status down
Post: RE: iMAC with Broadcom 14e4-1686 BCM57766 : link s...

(2017-06-13 15:24)NiKiZe Wrote:  What is needed is to find out which register in the NIC is affected, so 2 machines with the same nic (one working firmware and one with issues) and then dumping ...
SebastianRoth General 34 86,397 2017-07-22, 10:34
  Thread: iMAC with Broadcom 14e4-1686 BCM57766 : link status down
Post: RE: iMAC with Broadcom 14e4-1686 BCM57766 : link s...

Hi NiKiZe, thanks heaps for getting back so quickly. Hope we can figure this one out with your help. (2017-02-02 22:43)NiKiZe Wrote:  please test with the official ipxe git master. (so not the...
SebastianRoth General 34 86,397 2017-02-03, 18:30
  Thread: iMAC with Broadcom 14e4-1686 BCM57766 : link status down
Post: RE: iMAC with Broadcom 14e4-1686 BCM57766 : link s...

Bumping this post as we seem to have another one here https://forums.fogproject.org/topic/9278...ac-netboot iMac17,1 (Late 2015 model) as well as iMac14,1 with the same ethernet chip. Find more detai...
SebastianRoth General 34 86,397 2017-02-02, 21:46
  Thread: boot to grub2
Post: RE: boot to grub2

Is this on a BIOS or UEFI machine? Either way you should be able to generate a netbootable GRUB image that you can chainload to from iPXE. Read though those articles and you should be able to figure i...
SebastianRoth General 1 5,733 2016-06-03, 21:30
  Thread: ASUS AT5IONT-I: iPXE hangs on "iPXE Inicjalcizing devices..."
Post: RE: ASUS AT5IONT-I: iPXE hangs on "iPXE Inicjalciz...

Tried undionly.kkpxe (note the double 'k')?
SebastianRoth General 9 17,558 2016-06-03, 21:23
  Thread: iPXE EFI build fails with PXE_STACK defined
Post: RE: iPXE EFI build fails with PXE_STACK defined

PXE_STACK and EFI don't go together. Make it '#undef PXE_STACK' or leave commented. Then try compiling again. But you might want to change this option: Code: #define     &n...
SebastianRoth General 2 7,512 2016-04-26, 21:20
  Thread: [SOLVED] LoadImage in efi_image_probe fails on Lenovo ThinkPad Yoga 11e
Post: RE: LoadImage in efi_image_probe fails on Lenovo T...

OMG... We found out what the issue is/was. Too bad that we didn't check ALL the BIOS settings earlier. On that Yoga (and most probably on other models as well) there is a so called Embedded Security S...
SebastianRoth General 5 9,935 2016-04-05, 16:55
  Thread: [SOLVED] LoadImage in efi_image_probe fails on Lenovo ThinkPad Yoga 11e
Post: RE: LoadImage in efi_image_probe fails on Lenovo T...

Hi NiKiZe, thanks for your answer! (2016-04-04 18:28)NiKiZe Wrote:  The error: http://ipxe.org/7f048182 should give you link to exact line that is possible failure sources. (http://ipxe.org/2e...
SebastianRoth General 5 9,935 2016-04-04, 20:24
  Thread: [SOLVED] LoadImage in efi_image_probe fails on Lenovo ThinkPad Yoga 11e
Post: [SOLVED] LoadImage in efi_image_probe fails on Len...

Hi everyone, we have another odd issue with one of these new devices (see thread subject). We try loading the kernel (version 4.4.x, EFI_STUB enabled!) via ipxe.efi and see this: [img=800x248]https:/...
SebastianRoth General 5 9,935 2016-04-04, 15:14
  Thread: Broadcom BCM5709 cards not working
Post: RE: Broadcom BCM5709 cards not working

(2016-03-22 18:34)skibumatbu Wrote:  Thanks. lets hope a developer reads this and can take a look. Should I repost this in the developer forum/mailing list? The developers are more active on the...
SebastianRoth General 9 15,352 2016-03-23, 13:04
  Thread: Broadcom BCM5709 cards not working
Post: RE: Broadcom BCM5709 cards not working

(2016-03-22 14:43)skibumatbu Wrote:  I'm going to look at DHCP next. I don't have DHCP on that subnet (which is why I'm using ipxe) but it will be interesting to see what happens. From what we ...
SebastianRoth General 9 15,352 2016-03-22, 15:58