Search Results
Post Author Forum Replies Views Posted [asc]
  Thread: iso efi boot with memdisk
Post: RE: iso efi boot with memdisk

Unlikely to get it working this way. This is mentioned in the FAQ. For the old Gentoo based sysrcd I provided a patch that made it easier to PXE boot.
NiKiZe General 1 814 2021-05-08, 09:35
  Thread: Running script to download image
Post: RE: Running script to download image

chain does download curl does not run in iPXE You could have iPXE call a http server, which does the download. but you should be fine just fetching the rawdata url of github. Also the forum should n...
NiKiZe General 1 1,342 2021-03-10, 16:08
  Thread: Problem install Windows 10 to iSCSI target
Post: RE: Problem install Windows 10 to iSCSI target

Most likely your nic driver
NiKiZe General 7 6,928 2020-06-15, 12:34
  Thread: get DHCP/Option#67 inside a script
Post: RE: get DHCP/Option#67 inside a script

Did you try config command? Hint there is platform containing pcbios or efi
NiKiZe General 4 3,165 2020-05-14, 19:54
  Thread: MemTest86 UEFI not sending reports to TFTP when Started By iPXE
Post: RE: MemTest86 UEFI not sending reports to TFTP whe...

You probably need to figure out what memtest are using in terms of efi calls and then try to debug that, but hey, why not contact memtest about it? are you using ipxe.efi or snponly.efi and have you ...
NiKiZe General 4 3,111 2020-05-14, 15:30
  Thread: Stuck on initialising devices
Post: RE: Stuck on initialising devices

Another thing that you probably should try is, first of course to make sure you are using the latest version of iPXE. But you should also try to boot it directly from a USB stick, both grub and syslin...
NiKiZe General 4 3,053 2020-05-14, 15:26
  Thread: iPXE on win10 1909 and hyperV
Post: RE: iPXE on win10 1909 and hyperV

Gen2 is efi, make sure that you build the efi binary and then put it on a usb device manually at first, and then go from there.
NiKiZe General 2 2,651 2020-05-14, 05:53
  Thread: Increasing HTTPS security on FOG
Post: RE: Increasing HTTPS security on FOG

I recommend that you take a look at existing messages at the mailing list, and also github pullrequests. Simply, iPXE do not have the latest SSL features.
NiKiZe General 1 1,882 2020-05-14, 05:51
  Thread: Stuck on initialising devices
Post: RE: Stuck on initialising devices

output of lspci -nn (linux command) Grab all lines that has "Ethernet" on them, or just take the whole bunch so that we can see your PCI layout.
NiKiZe General 4 3,053 2020-05-14, 05:50
  Thread: EFI + IPXE woes
Post: RE: EFI + IPXE woes

is secure boot disabled? Have you made sure that your setup are correctly configured to handle the efi network boot scenario (especially sending the correct binary) You should verify your setup with ...
NiKiZe General 2 2,364 2020-05-14, 05:48
  Thread: Mac mini with Broadcom BCM57766/BCM57762 : link status down
Post: RE: Mac mini with Broadcom BCM57766/BCM57762 : lin...

To me this seems to be the same problem, so you should write in the existing thread. What are you using when you boot from USB? a, ipxe.iso - which is pure legacy code. not efi. Reason for not worki...
NiKiZe General 2 2,953 2020-05-14, 05:46
  Thread: get DHCP/Option#67 inside a script
Post: RE: get DHCP/Option#67 inside a script

what about ${67} or ${filename} also run the config command and see what pop up
NiKiZe General 4 3,165 2020-05-14, 04:27
  Thread: Realtek 2.5G bps NIC(8125 chipset)
Post: RE: Realtek 2.5G bps NIC(8125 chipset)

Probably not, Linux drivers and iPXE drivers are not the same, even if some have been ported from Linux. However the best approach is to write them from scratch based on dataseheets. Suggestion is to...
NiKiZe General 1 2,155 2020-05-06, 04:24
  Thread: Setting console picture breaks the display when Ubuntu boots into kernel
Post: RE: Setting console picture breaks the display whe...

Not sure why you would boot an iso, but what is the actual error you are seeing?
NiKiZe General 2 2,516 2020-05-06, 04:20
  Thread: ISO build - Not taking config options
Post: RE: ISO build - Not taking config options

in one case you are building an efi binary, in the other a pcbios image, are you sure it is actually booting the correct thing and not something else? Also images not visible.
NiKiZe General 2 2,474 2020-05-06, 04:19
  Thread: Tool for user selection of interface
Post: RE: Tool for user selection of interface

there is already scripts written that does this for you For example here: https://gist.github.com/robinsmidsrod/3871687
NiKiZe General 1 2,071 2020-05-06, 04:17
  Thread: How to submit patches for consideration?
Post: RE: How to submit patches for consideration?

Sign up to the mailing list and send them there as per standard linux best practice, or use github. Also read http://ipxe.org/admin
NiKiZe General 1 1,957 2020-05-06, 04:14
  Thread: Why Esxi 6.5 or 6.7 fail to start setup GUI via iPXE
Post: RE: Why Esxi 6.5 or 6.7 fail to start setup GUI vi...

iPXE will only support booting efi files in efi environments, if there is no EFI to boot then there is nothing that can be done. If there is an EFI that can be booted, but don't work with iPXEs standa...
NiKiZe General 28 27,711 2019-12-19, 07:26
  Thread: Why Esxi 6.5 or 6.7 fail to start setup GUI via iPXE
Post: RE: Why Esxi 6.5 or 6.7 fail to start setup GUI vi...

I would rather say that: How would you boot Esxi on a EFI only platform over the network? It seems that it is vmware that don't provide the tools you need. Report the issue with Vmware Or your hardw...
NiKiZe General 28 27,711 2019-12-18, 16:37
  Thread: Booting ipxe from usb causes megaraid_sas driver to fail
Post: RE: Booting ipxe from usb causes megaraid_sas driv...

So this issue happens when you boot via iPXE, but not when you boot the exact same kernel directly from USB? Or what I'm trying to ask is, why is this an "iPXE realated problem"? You are always boot...
NiKiZe General 1 2,774 2019-12-18, 16:36