Search Results
Post Author Forum Replies Views Posted [asc]
  Thread: skip unplugged network cards
Post: skip unplugged network cards

Hi, so after working with iPXE for the last few months and having a working environment the only thing that bugged me is having to wait for ipxe to try and configure every NIC that is present even if ...
silver310 General 1 5,237 2016-01-05, 15:39
  Thread: Detect if bios or uefi possible?
Post: RE: Detect if bios or uefi possible?

(2015-12-04 01:46)layzer253 Wrote:  Is there a function similar to how you can check if you are booted via BIOS or UEFI in a menu simliar to how you can check cpu architecture? My current setup ...
silver310 General 2 14,206 2016-01-02, 08:34
  Thread: Cannot boot vmlinuz in efi
Post: RE: Cannot boot vmlinuz in efi

SOLVED, finally. So after 3 days I finally found a solution/workaround, I'll explain everything so other people might use this. Basically it all comes down to GRUB2, I created a standalone bootx64.ef...
silver310 General 15 49,023 2015-12-31, 11:43
  Thread: Cannot boot vmlinuz in efi
Post: RE: Cannot boot vmlinuz in efi

(2015-12-30 13:47)NiKiZe Wrote:   (2015-12-30 13:43)silver310 Wrote:  could not boot: Error 0x7f048281 (http://ipxe.org/7f048281)" What am I doing wrong? It says that the efi can't be sta...
silver310 General 15 49,023 2015-12-30, 13:52
  Thread: Cannot boot vmlinuz in efi
Post: RE: Cannot boot vmlinuz in efi

OK so I've been trying to use syslinux to boot this image, but can't get ipxe to chain. In legacy mode it works fine with the following menu entry: set pxelinux ${tftp-server}/pxelinux/legacy set ...
silver310 General 15 49,023 2015-12-30, 13:43
  Thread: Cannot boot vmlinuz in efi
Post: RE: Cannot boot vmlinuz in efi

(2015-12-28 21:53)MultimediaMan Wrote:   (2015-12-28 16:24)silver310 Wrote:  OK I get it. Any advice on how to pass a conf file to grub so it'll boot automatically? I tried '' chain ${...
silver310 General 15 49,023 2015-12-29, 09:55
  Thread: Cannot boot vmlinuz in efi
Post: RE: Cannot boot vmlinuz in efi

OK I get it. Any advice on how to pass a conf file to grub so it'll boot automatically? I tried '' chain ${http-images} /rhel67/EFI/BOOT/BOOTX64.efi ${http-images} /rhel67/EFI/BOOT/BOOTX64.co...
silver310 General 15 49,023 2015-12-28, 16:24
  Thread: Cannot boot vmlinuz in efi
Post: RE: Cannot boot vmlinuz in efi

Yeah I just read about the efi stub issue. I tried doing that with bootx64.efi but couldn't figure out how to automate it to boot vmlinuz immediately. How hard would it be to compile a kernel for r...
silver310 General 15 49,023 2015-12-28, 15:53
  Thread: Cannot boot vmlinuz in efi
Post: Cannot boot vmlinuz in efi

Hello, I've recently cam across this problem when trying to boot an installation iso of RHEL 6.7 I can boot centos 7, fedora 22, and rhel 7 with no issues in EFI and legacy mode. However i cannot boot...
silver310 General 15 49,023 2015-12-28, 10:57
  Thread: Failing to download via http 1 out of 5 times.
Post: RE: Failing to download via http 1 out of 5 times.

(2015-12-15 20:38)danberk Wrote:  Which HTTP server are you using? Apache on Centos 7
silver310 General 6 16,133 2015-12-22, 13:40
  Thread: Failing to download via http 1 out of 5 times.
Post: RE: Failing to download via http 1 out of 5 times.

(2015-12-11 21:42)danberk Wrote:  Hi! I put that in, I had a custom Apache Tomcat server serving files, and I was getting a error if I didnt set the content type manually. Where do i configure ...
silver310 General 6 16,133 2015-12-13, 07:53
  Thread: Failing to download via http 1 out of 5 times.
Post: RE: Failing to download via http 1 out of 5 times.

(2015-12-01 16:10)SebastianRoth Wrote:  Do you see the HTTP requests in your apache access log or possibly errors in apache error log when you see "couldn't retrieve file"? When the download co...
silver310 General 6 16,133 2015-12-02, 09:41
  Thread: Failing to download via http 1 out of 5 times.
Post: Failing to download via http 1 out of 5 times.

Hi, I've set up an iPXE server, all file downloads are done via http. The problem is that every 1 out of 5 times it'll fail to download the file, it'll show me an error "couldn't retrieve file" and re...
silver310 General 6 16,133 2015-12-01, 10:33
  Thread: detect legacy/uefi
Post: RE: detect legacy/uefi

Thanks I've found a way around the DHCP server, using a proxy DHCP locally (we can't configure the main DHCP our-self). As for the docs, I've been reading the site and the help/docs there are really ...
silver310 General 2 6,348 2015-11-22, 07:48
  Thread: Booting clonazilla/parted magic in UEFI
Post: RE: Booting clonazilla/parted magic in UEFI

Wow thanks NiKiZe, adding initrd=filename fixed it and now everything boots up fine, although a little slower then in Legacy, but at least it works. I've almost given up after reading that iPXE EFI mo...
silver310 General 6 19,053 2015-11-22, 07:42
  Thread: Booting clonazilla/parted magic in UEFI
Post: Booting clonazilla/parted magic in UEFI

Hi, I've finally finished with configuring iPXE for our lab. In legacy mode everything works fine, but in UEFI I can't seem to boot clonezilla or Parted magic in UEFI mode, I always get the error: "Ke...
silver310 General 6 19,053 2015-11-19, 14:55
  Thread: detect legacy/uefi
Post: detect legacy/uefi

Hi, I've been successful in building snponly.efi and undionly.kpxe, and be able to boot them from a locally created DHCP server. Now i want to implament this in our lab, but the DHCP team tells me the...
silver310 General 2 6,348 2015-11-08, 09:57