Search Results
Post Author Forum Replies Views Posted [asc]
  Thread: Problem with iPXE and AoE
Post: RE: Problem with iPXE and AoE

Unfortunately I do not have enough time right now to build and test each commit (maybe in a few days when workload is lower), I simply needed to have the thing working by this week, which I have alrea...
Nestor General 15 44,328 2012-09-23, 14:37
  Thread: Problem with iPXE and AoE
Post: RE: Problem with iPXE and AoE

(2012-09-21 13:55)robinsmidsrod Wrote:  That problem you're having with undionly.kpxe (and not with ipxe.iso) is probably that undi only uses the network stack (PXE) of your network card. It cou...
Nestor General 15 44,328 2012-09-21, 17:14
  Thread: Problem with iPXE and AoE
Post: RE: Problem with iPXE and AoE

Short update: since the inconsistency in behavior between undionly.kpxe and the ISO was suspicious, I made a test replacing the executable with gpxe-1.0.1-undionly.kpxe from gPXE project, and this tim...
Nestor General 15 44,328 2012-09-20, 16:33
  Thread: Problem with iPXE and AoE
Post: RE: Problem with iPXE and AoE

Allright, I captured packet traces of both booting from undionly.kpxe and from a CD. There are several packets in each dump, and I am not familiar enough with iPXE and SAN/AoE so as to correctly inter...
Nestor General 15 44,328 2012-09-20, 13:56
  Thread: Problem with iPXE and AoE
Post: RE: Problem with iPXE and AoE

mcb30 Wrote:That may not be enough. AoE support needs to be included within the initrd, otherwise the system won't be able to connect to its own root filesystem. (Consider what happens once the kern...
Nestor General 15 44,328 2012-09-19, 14:38
  Thread: Problem with iPXE and AoE
Post: RE: Problem with iPXE and AoE

mcb30 Wrote:From a very quick search using terms such as "Debian AoE boot", it looks as though you may need to make some modifications to the base Debian install to make it AoE boot-capable. I did ma...
Nestor General 15 44,328 2012-09-18, 22:28
  Thread: Problem with iPXE and AoE
Post: RE: Problem with iPXE and AoE

mcb30 Wrote:It looks as though your AoE target is simply not responding. You could try capturing a packet trace to see what's really happening. I doubt this is the case, because when I booted from t...
Nestor General 15 44,328 2012-09-18, 14:15
  Thread: Problem with iPXE and AoE
Post: RE: Problem with iPXE and AoE

(2012-09-18 11:25)mcb30 Wrote:   (2012-09-17 16:46)Nestor Wrote:  The problem is that although the client does begin to boot from the network, iPXE does not detect the SAN device. Could yo...
Nestor General 15 44,328 2012-09-18, 13:50
  Thread: Problem with iPXE and AoE
Post: Problem with iPXE and AoE

Hello, I am trying to implement a small LAN of diskless clients using iPXE to boot from an AoE SAN device, and dnsmasq for DHCP and TFTP. In order to make the image, I placed a hard drive in one of ...
Nestor General 15 44,328 2012-09-17, 16:46