Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lenovo ToolCenter img2a Exec Format Error
2017-09-20, 20:08
Post: #4
RE: Lenovo ToolCenter img2a Exec Format Error
(2017-09-20 19:49)mcb30 Wrote:  
(2017-09-20 17:11)rweisman Wrote:  When I run the linux file command this is the output:
file img2a
img2a: Linux kernel x86 boot executable bzImage, version 2.6.32-358.23.2.98.Toolscenter5_1.x86_64 (mockbuild@bldx1) #1 S, RO-rootFS, swap_dev 0x3, Normal VGA

Any Ideas on how to load this kernel?

The kernel is almost certainly too old to be booted directly as a UEFI executable. You will need to use a more recent kernel to boot directly via iPXE. (Alternatively, you can use iPXE to load an intermediate bootloader such as GRUB or ELILO).


I noticed that the BZIMAGE does not appear in the header on Boot. I tried un-commenting that in the config/general.h file, but get compile errors.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Lenovo ToolCenter img2a Exec Format Error - rweisman - 2017-09-20 20:08

User(s) browsing this thread: 1 Guest(s)