Post Reply 
Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows 10 (1804) installation on iscsi device
2018-09-03, 18:26 (This post was last modified: 2018-09-03 20:14 by scratchy.)
Post: #3
RE: Windows 10 (1804) installation on iscsi device
(2018-09-03 18:03)NiKiZe Wrote:  The link you are pointing to does the horrible thing of setting up an winpe iso that is booted via sanboot, there is much better tools for that - wimboot.

Sorry about that i also for sure tried out the wimboot method, from This didnt do a difference

(2018-09-03 18:03)NiKiZe Wrote:  You have written on IRC - and I can respond there to try and help you - but it won't do much good if you leave the channel.

I restarted my computer for pxe testing purposes sorry about that

(2018-09-03 18:03)NiKiZe Wrote:  If instead what you want to do is install from a booted winpe - onto a iSCSI target that is a different matter that have had many getting gray hairs.

i dont get this part sorry?

(2018-09-03 18:03)NiKiZe Wrote:  * What is the NIC you are using?

Virtualbox default NIC (virtual client) Intel PRO/1000 MT Desktop (82540OEM) / Intel V82579V / Different realteks on physically hardware

(2018-09-03 18:03)NiKiZe Wrote:  * Have you modified the winpe in any way (especially added drivers)

Tried both, vanilla winPE as well as different scripts for example one which i copy and pasted together ( ) for adding iscsicpl stuff (i think stuff like this is outdated since a long time)? I didnt touched drivers in WinPE.

(2018-09-03 18:03)NiKiZe Wrote:  * Are the winpe from the same source as the installation files you are using?

Yes as WINPE was always matching the iso which im installing. Tried here 1803,1706,1607

(2018-09-03 18:03)NiKiZe Wrote:  After reading over what you have written once again, I'm quite sure that what you are seeing is the windows setup application starting and is unable to find any installation media.

Thats sadly wrong, i see the windows setup, as well as the installation media also the windows setup copys data over but the last step (!) shortly before the reboot fails with the mantadory driver error message (will attach a screen soon)

(2018-09-03 18:03)NiKiZe Wrote:  What you have to do (and which is described on that site) is to open a prompt (press shfit+f10) and run wpeinit etc as described in and then you will have to mount a installation share.

I don't think anyone have or will be able to get a pure windows iso to sanboot and be available as an installation media, the reason being that network needs to be started properly before any iSCSI devices will be detected.

(2018-09-03 18:03)NiKiZe Wrote:  a few other notes:
* don't use set keep-san 1 - legacy and not needed
* don't use syslinux, iPXE should be able to do everything on it's own
* don't use memdisk - if you are than that probably explains your issues even more.

All three things i already figured out today, replaced syslinux (menu management is possible with ipxe as well), memdisk was replaced by wimboot and keep-san i wasnt sure, but if you say i can remove it ill do.

(2018-09-03 18:03)NiKiZe Wrote:  If nothing of this helps then post exact configuration, including NIC etc with pciid as described above, as well as iPXE scripts that you are using, a link to image with the screen that you are seeing with the error message. - The goal with the description should be that anyone can recreate your exact scenario, that way more people can reproduce and help you find a solution.

Heres my windows-10-installation section

sanhook --drive 0x80 ${ISCSI_FULL_URL_WIN10}
kernel ${boot-url}/distros/tools/wimboot-2.6.0/wimboot

initrd ${boot-url}/distros/windows/winpe/startup/10/1803/install.bat                                install.bat
initrd ${boot-url}/distros/windows/winpe/startup/winpeshl.ini                                winpeshl.ini
#initrd ${boot-url}/distros/windows/winpe/WinPE_amd64_1803/media/bootmgr                      bootmgr
#initrd ${boot-url}/distros/windows/winpe/WinPE_amd64_1803/media/EFI/Boot/bootx64.efi          bootx64.efi

initrd ${boot-url}/distros/windows/winpe/WinPE_amd64_1803/media/Boot/BCD                     BCD
initrd ${boot-url}/distros/windows/winpe/WinPE_amd64_1803/media/Boot/boot.sdi                boot.sdi
initrd ${boot-url}/distros/windows/winpe/WinPE_amd64_1803/media/sources/boot.wim             boot.wim

[Image: errormessage.png?dl=1]

[Image: fail.png?dl=1]
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Windows 10 (1804) installation on iscsi device - scratchy - 2018-09-03 18:26

User(s) browsing this thread: 1 Guest(s)