The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
wimboot not releasing system memory?
2019-01-04, 12:59 (This post was last modified: 2019-01-04 13:40 by steve6375.)
Post: #1
wimboot not releasing system memory?

Happy New Year!

I am the developer of Easy2Boot (, I posted this Q on but have had no response, so I am posting here.

I am using wimboot to boot from a Windows ISO from a USB flash drive using grub4dos

A sample grub4dos menu is:

title Install Windows10x64UK_Oct_2018 using wimboot method
map /Windows10x64UK_Oct_2018.iso (0xff)
map --hook
root (0xff)
# the root path now points to the files inside the ISO file
# hd0,0 is the USB drive that we booted from
kernel (hd0,0)/wimboot image=2
initrd @startup.bat=(hd0,0)/startup.bat @winpeshl.ini=(hd0,0)/winpeshl.ini @bcd=/boot/bcd @boot.sdi=/boot/boot.sdi @boot.wim=/sources/boot.wim

I am using current version of wimboot (size 51,392 bytes, 17 May 2017)
When I boot from a virtual system (Virtual Box) which has 1024MB of RAM, I get various memory problems reported by WinPE.
If I run taskmgr.exe it reports Total Memory 683, Cached 107, Available 27, Free 5.

If I run the same ISO using a standard grub4dos mechanism, taskmgr.exe reports the system has 1023MB of memory and I get no memory issues (Total 1023, Cached 262, Available 394, Free 140).

If I increase the amount of RAM to 2GB there is no problem using wimboot.

Is this to be expected or has wimboot failed to release some memory?

P.S. As a second question, is there a way to inject a file into X:\ (root of X: drive).
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
wimboot not releasing system memory? - steve6375 - 2019-01-04 12:59

User(s) browsing this thread: 1 Guest(s)