The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Very slow kernel/initrd download (RPI + U-boot)
2019-08-30, 02:29
Post: #1
Very slow kernel/initrd download (RPI + U-boot)
- Raspberry Pi 3 B+
- RPI Bootloader -> U-boot 64-bit -> iPXE 64-bit snp.efi

So far I have the Raspberry Pi successfully booting into u-boot (a popular ARM bootloader), which then chainloads iPXE snp.efi. U-boot steps shown here, although I'm trying to use HTTP rather than ISCSI. iPXE with snp.efi target successfully detects the network devices, gets an IP from DHCP, and starts the kernel download.

The issue is the kernel download is incredibly slow, taking 10+ minutes to download a 6MB kernel file. The Raspberry Pi only supports a 100-Mbps max speed, but this is down at 50-kbps or so. Appreciate any suggestions on how to debug this.

Other stuff I've tried:
- 32-bit U-boot + 32-bit iPXE has the same issue
- Tried building the recently added `rpi.efi` target using command shown here, but this build failed to detect the network devices
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
Very slow kernel/initrd download (RPI + U-boot) - ljfranklin - 2019-08-30 02:29

User(s) browsing this thread: 1 Guest(s)