Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
chainloading (undionly.kpxe) ipxe is failing.
2019-12-12, 21:01
Post: #3
RE: chainloading (undionly.kpxe) ipxe is failing.
(2019-12-12 18:41)NiKiZe Wrote:  Screenshot not available.

If you press ctrl+b and then type dhcp, does that fail as well?, with what error?

We are seeing TXE:1 in the message, however not what iPXE tried to do when it happened.
And points us towards it being that no interface was open.

Did you maybe use ctrl+b and then tried to chain immediately, without first running dhcp or other ifopen command?

Sorry about the wrong link. Corrected the screenshot link.
My pxe server sends path to undionly.kpxe when host sends the first pxe/Discovery request. Which hosts seems to download fine and put the undionly stack on nic.
Host then sends another pxe/discovery request (this time with userclass = "iPXE") in return my pxe server sends an ipxe script:


cpuid --ext 29 && set arch x64 || set arch x86
kernel wimboot
initrd ${arch}/images/bcd BCD
initrd boot.sdi boot.sdi
initrd ${arch}/images/mywinpeimage.wim boot.wim

At this point host fails but I don't if failed to download the ipxe script or failed to process it.
It seems that when undionly.kpxe loads then networking stack does not work.

Host has mallnox connect x3 network card. It does have ipxe but I am trying to test if undionly.kpxe could be our solution to cover both legacy and newer network cards.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: chainloading (undionly.kpxe) ipxe is failing. - vpnchoudhary - 2019-12-12 21:01

User(s) browsing this thread: 1 Guest(s)