Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ipxe suddenly very slow
2012-02-28, 15:05
Post: #2
RE: ipxe suddenly very slow
(2012-02-11 17:40)Snowbird Wrote:  Hello everyone,

Back in march of last year, I figured out how to boot my computer using ipxe, for that I used dnsmasq with dhcp and tftp enabled and configured to hand undionly.kpxe to my computer. Everything worked flawlessly, I was able to boot on my CD to install win7 over an iSCSI target, the installation was completed in less than 20 minutes. Then I installed my regular apps, and was ready to use my system. The performance was actually very very good, almost as good as if I had used a real HDD !! Win7 was booting in less than 30 seconds ! I used this computer for more than 8 months with no problem at all.

One day , I powered on my computer and it took about 45 minutes to boot, everything was still working, there was no file missing or corrupted file, it was just very very slow, actually I was able to monitor the bandwidth used, and it was around 400 kBytes/s. First thing that comes to mind is to check the windows log, that's what I did and there was nothing special, except some alerts regarding iSCSI (about delay, retransmission, etc.) that was something new in the log. At this moment, you might think (just like I did) that it's an iSCSI problem obviously, and that has nothing to do with the boot process of ipxe that works just fine. Well, I would say : maybe ! it has been more than 3 months that I'm trying to find out went wrong suddenly and how I could fix this. So here's what I did :

I created a new target, to make a brand new installation of win7, the installation took a very very long time around 4 hours (as opposed to the first time where it took about 20 minutes), I tried this same process several times with the following setup :

1/ Using the same PC and same NAS, and the same Win7 CD (original)
2/ Using the same PC and another NAS, and the same Win7 CD (original)
3/ Using another PC and same NAS, and the same Win7 CD (original)
4/ Using another PC and another NAS, and the same Win7 CD (original)

Since there was no improvement (still 4 hours were needed to install Win7), I changed the gigabit switch too, and it was the same.

Then I thought that my undionly.kpxe file might be corrupted in some way, so I downloaded it again from here (it was a newer version), and replaced it in my TFTP location, and.... same result !

Then I tried another thing with the first PC, I put a real HDD inside, and made a new Win7 install on it, everything worked perfectly. And I had an idea, trying to connect to my iSCSI target (the same one that is slow) via the windows iscsi initiator, surprise !! I was able to download/upload files at an average speed of 50 MBytes/s !!! (from/to iSCSI target to/from PC's HDD).

That's a long story, isn't it Smile But my knowledge limit is reached, I don't know what else to try to make it work as it used to. It worked perfectly before this famous ordinary day !

NAS2 = Synology

PC1 = Lenovo (intel nic)
PC2 = Acer (broadcom nic)

Any help, clue, advice is welcome.
Thank you for taking the time to read ! Smile

Have you used the same NIC?

In the case where you switched the PC, did you use any of the original PCs parts?

Did you enable jumbo frames or even disable it for that matter?
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
ipxe suddenly very slow - Snowbird - 2012-02-11, 17:40
RE: ipxe suddenly very slow - AnRkey - 2012-02-28 15:05
RE: ipxe suddenly very slow - lamont - 2012-03-07, 21:59

User(s) browsing this thread: 1 Guest(s)