The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iscsi boot/install fails
2012-04-11, 18:55
Post: #1
iscsi boot/install fails
Hello again Smile
I posted into another post about this, so please don't wonder about it, it is somewhat urgent :/
I have a problem right now with iscsi boot.
Before i had a winPE3 image to be loaded at boot time and to be installed into an iscsi target. after some hassle it worked. the target got acknowledged by the initiating windows 7 and it was ready as a disk to install to. I did and rebooted - happily it worked for some time and restarts.
Some days later it did not work anymore. Neither the installed OS (during start there is a bluescreen) nor for the winPE image.

My winPE has got the iscsi service enabled and via iscsicli.exe connects to the targets. Windows Setup sees the disk but there it claims that it cannot be installed to the disc because:
"Windows cannot be installed to this disk. iSCSI deployment is disabled since no NICs referenced in the iBFT can be resolved to actual NT-visible devices."

So far i found out about the ibft which should be passed to the OS. But i think it should be passed

My Script looks like:
set user-class iPXE
set keep-san 1
sanboot ${root-path}
chain installer/windows/win7-U/pxeboot.0

Of course I replaced the chain line with the shell to see what happens.
It registers as san-device 0x80 and fails (since there is no image to boot)
then i chain manually to find above mentioned problem.

I also tried sanhook since it makes more sense, but it results in the same problem.
The user-class is set because my dhcp will then give away the root-path to ipxe.

Any hint?
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
iscsi boot/install fails - Markus - 2012-04-11 18:55
RE: iscsi boot/install fails - Markus - 2012-04-12, 18:46
RE: iscsi boot/install fails - Markus - 2012-04-20, 22:01
RE: iscsi boot/install fails - Markus - 2012-06-03, 15:41
RE: iscsi boot/install fails - Markus - 2012-06-04, 20:05

User(s) browsing this thread: 1 Guest(s)