Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Intel BootUtil no longer understands gPXE/iPXE images?
2012-10-30, 17:51 (This post was last modified: 2012-10-30 21:03 by Sedorox.)
Post: #3
RE: Intel BootUtil no longer understands gPXE/iPXE images?
I recently ran into this myself.
If you go and download the latest preboot.exe (I got mine from here:
version 17.4, which gives a bootutil.exe version of, it apparently does not like the rom format that iPXE presents. When I try to use it, I get the following (I renamed the rom file for later):

>bootutil -nic=1 -up=pxe -file=80861229.iba

Intel® Ethernet Flash Firmware Utility
BootUtil version
Copyright © 2003-2012 Intel Corporation

ERROR: Input file invalid format

Port Network address Series WOL Flash Firmware Version
==== =============== ====== ==== ================== =======
1 0002B365A2E0 10/100 YES Flash Unknown

(Note, echo %errorlevel% shows error 14).
Also, I tried the bootutil in Linux, and got the same error. I also tried many forms of the filename, and it didn't change the error.

However, grabbing the old prorpl.exe, from
version 10.4, IBAUtil version, it works fine, with the following:

>ibautil.exe -nic=1 -restore
Intel® Boot Agent Utility
IBAUtil Version
Copyright © 2002-2004 Intel Corporation

Restoring image on NIC1 from file 80861229.IBA...done

NIC Network Address Series WOL Boot ROM Type Version
=== =============== ====== === ================ ========
1 0002B365A2E0 10/100 YES PXE/RPL 88.106.129

Indeed, upon reboot, I'm presented with iPXE.

Trying the suggestion above (also suggested by Sha0 on IRC), I reduced the size of the image, and padded it to the size of one saved from the bootutil, and I still got the same error message.

At this point, it seems either the ROM needs to be saved in a new (or old -- as references to FLB exist in the bootutil docs, but say it's old..) format for the bootutil, or we have to use the old ibautil to flash it.

I also posted to the mailing list, to hopefully spur conversation there too:
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Intel BootUtil no longer understands gPXE/iPXE images? - Sedorox - 2012-10-30 17:51

User(s) browsing this thread: 1 Guest(s)