The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HP z400 (no network no Gigabit link NIC=BCM5764m)
2012-10-01, 14:00 (This post was last modified: 2012-10-14 13:41 by Torgeir.)
Post: #1
HP z400 (no network no Gigabit link NIC=BCM5764m)

I hit the wall "again". Now with a HP z400 Workstation. No network.
With an extra network card (broadcom netXtreme) net on that card is working as it should.

Both (ipxe.pxe, ipxe.lkrn) are based on the same source. iPXE 1.0.0+ (09cc). This time I have not tried with any of the undionly (k/kk/kkk), because ipxe.pxe was the one working for most of our computers.

There is no newer BIOS upgrade available for this model.

Any thoughts/ideas?

edit 2: Was a problem with gigabit link. 100Mbit was working OK though.
A patch brom a Broadcom developer fixed the problem.

edit: all of the undionly.kpxe/kkpxe/kkkpxe is working OK. But with undionly I had troubles with some other stuff...

Is it possible to solve this? Can I have some form of fallback from ipxe.pxe to undinoly.kpxe if no network. With some smart ipxe scripting?

This config is pxelinux-4.05, chainloading ipxe.pxe. I have not tried with "dhcp option user-class iPXE" on a closed LAN (will do tomorrow).

Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
HP z400 (no network no Gigabit link NIC=BCM5764m) - Torgeir - 2012-10-01 14:00

User(s) browsing this thread: 1 Guest(s)