The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] initrd/vmlinuz issues: Losing my mind...
2013-06-08, 17:11 (This post was last modified: 2013-07-21 01:12 by MultimediaMan.)
Post: #1
[SOLVED] initrd/vmlinuz issues: Losing my mind...
Sometime between March and now, I've discovered a problem with my home network boot solution.

ALL Linux distros I use (CentOS/ Scientific Linux/ VMware ESX 4.1) which use the standard initrd/vmlinuz load combinations panic at pretty much the exact same point during the net boot.

The messages are, without fail, are some variation of "Failed to find Ramdisk at 0..."

Googling reveals this message to be usually the result of a corrupted image. CRC checks on the actual files are good (The installation ISOs are mounted as iso9660 Read-Only File systems)

The problems seem to be occurring after I rearranged the directory structure.

This leads me to wonder: Is there is a directory depth limitation with either iPXE or the Linux kernel itself?


These addresses will not resolve outside my network, and are for information only.

Both load fine in iPXE, but I wonder if the directory path length might be too deep for Anaconda? Maybe around 127-128 characters?


"Thus far, you have been adrift within the sheltered harbor of my patience..."
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
[SOLVED] initrd/vmlinuz issues: Losing my mind... - MultimediaMan - 2013-06-08 17:11

User(s) browsing this thread: 1 Guest(s)