Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iPXE exit fails
2013-06-25, 13:20
Post: #5
RE: iPXE exit fails
There isn't really a lot you can do, except making sure you're running the latest BIOS for your machine. You could of course report it as a bug to your hardware vendor, but I have had little luck with that approach myself. YMMV.

I've had a similar problem on my HP Compaq 6730b, which is using the tg3 driver. Whenever I exit from network boot (using either undionly.kpxe or ipxe.pxe) it just sits there for about 30 seconds doing nothing before it starts booting the local disk. I don't get a "no more network devices" message, though.

Have you tried changing your BIOS boot order around and see if this still causes an issue once you exit from network boot? If that doesn't work, have you tried disabling the network boot in your BIOS, put ipxe on a usb stick or CD and boot using that one instead of the network card? If you exit from that one, does it actually boot local? If so, your issue might be in the vendor PXE firmware, not in your BIOS. In that case, the hard job is to replace/upgrade the vendor PXE firmware in your BIOS, which is a tricky thing and could brick your motherboard. You could work around the issue by booting ipxe from a tiny usb stick or sdcard you keep permanently attached to the machine. I use a Lexar USB-to-MicroSD adapter which is tiny for that purpose.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
iPXE exit fails - jamesosbourn - 2013-06-24, 15:26
RE: iPXE exit fails - mcb30 - 2013-06-24, 17:11
RE: iPXE exit fails - jamesosbourn - 2013-06-24, 22:19
RE: iPXE exit fails - jamesosbourn - 2013-06-25, 12:23
RE: iPXE exit fails - robinsmidsrod - 2013-06-25 13:20
RE: iPXE exit fails - nicodejong - 2013-08-02, 08:21

User(s) browsing this thread: 1 Guest(s)