Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ipxe timeout
2014-05-20, 01:55 (This post was last modified: 2014-05-20 02:03 by mastacontrola.)
Post: #9
RE: ipxe timeout
(2014-05-19 08:47)robinsmidsrod Wrote:  You haven't posted the contents of your embedded ipxe script, so it's a bit hard to be sure what's actually wrong.
I'm very sorry about that.

iPXE Embedded Script
sync --timeout 500
dhcp || goto retry
chain default.ipxe

That is the script. The sync --timeout 500 was an attempt, initially, thinking it was something to deal with a timing issue. I tried 5000, 300000, 120000, and other variations but the problem still occurs. I've also tried sleep commands in place of sync as I understand sync --timeout only waits for background jobs to complete for the specified period of time. If they complete before the timeout it'll return back to ipxe to begin with.

While waiting for my post to become "posted" I set and looked at all possible things that could've changed as the file: (rev 1312) seems to work very consistently.

The only two files that, I think could be causing the issue, changed from the date of this file and seeing this error pop up was drivers/net/intel.c and drivers/net/intel.h.

While this file consistently works, as it doesn't have the drivers built into the undionly, my VirtualBox still gives issues. For that I don't mind using the ipxe.pxe style file.

(2014-05-19 08:47)robinsmidsrod Wrote:  My guess is that you don't have either an ifopen or dhcp/ifconf command in your embedded script, which is why the interface stays in a closed state. I'm a regular user of VirtualBox, and I generally use ipxe.pxe which is compatible with all of the emulated NICs in VirtualBox. I would recommend using one of the intel vnics for best performance.

You should also upgrade to include commit ca93505 (3 days ago), as it contains a bugfix to the NFS download protocol, which I notice you have enabled.

At the time of writing this posting I was on the latest commit. I've no issues trying again, but although I compile the NFS into it (possibly for future use) we don't currently boot through it. It's more just a "better to have than not need it......" situation.

Am I correct with my understanding of the variances of undionly.kpxe and ipxe.kpxe? Ipxe.kpxe contains drivers where undionly.kpxe only has a minimal set?

Also, I tried compiling a new git pull using the "old" intel.c and intel.h drivers, but this doesn't seem to have helped though I'm still awaiting response.

Thank you for your time.
(2014-05-19 12:55)TheUltimateUnltd Wrote:  I had the same error number. Rebuilding from source fixed it.

I only ever build from source. I did try the files from, but received the same errors from both files.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
ixpe time-out - oneindelijk - 2014-02-12, 20:20
RE: ipxe timeout - robinsmidsrod - 2014-02-14, 09:56
RE: ipxe timeout - oneindelijk - 2014-02-14, 13:25
RE: ipxe timeout - robinsmidsrod - 2014-02-20, 09:29
RE: ipxe timeout - oneindelijk - 2014-02-20, 10:05
RE: ipxe timeout - mastacontrola - 2014-05-16, 02:00
RE: ipxe timeout - robinsmidsrod - 2014-05-19, 08:47
RE: ipxe timeout - mastacontrola - 2014-05-20 01:55
RE: ipxe timeout - mastacontrola - 2014-05-30, 00:53
RE: ipxe timeout - TheUltimateUnltd - 2014-05-19, 12:55
RE: ipxe timeout - mastacontrola - 2014-05-30, 12:18
RE: ipxe timeout - mastacontrola - 2014-05-30, 17:11
RE: ipxe timeout - mcb30 - 2014-06-02, 10:49
RE: ipxe timeout - mastacontrola - 2014-06-02, 12:24
RE: ipxe timeout - mastacontrola - 2014-06-02, 16:41
RE: ipxe timeout - robinsmidsrod - 2014-06-02, 10:39

User(s) browsing this thread: 1 Guest(s)