The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
wimboot & multicore on esx issues
2014-09-30, 17:12
Post: #1
wimboot & multicore on esx issues

I'm currently experimenting issues when booting WinPE 3.1 and 5.0 through iPXE/wimboot on an ESXi 5.5 64bit guest.

I'm using vanilla WinPE distributions as explained here:

The problem occurs only when the ESXi guest platform has more than one core (both WinPE 3.1 and 5.0 boot well when there is only one core).
The same iPXE configurations work well when booting on a physical platform (64bit multicore) or a VirtualBox guest (also 64bit multicore).

The problem also does not occur if I transfer the WinPE distribution on an ISO file and use this file as a CD/DVD device for the ESXi guest (64bit multicore). It ends up with a working WinPE prompt.

So the current status when iPXE booting a 64bit multicore ESXi guest is:
- on WinPE 3.1, it ends up with a BSOD 0x7E ( with the cause [0xC0000005: STATUS_ACCESS_VIOLATION]
- on WinPE 5.0, it ends up with a black screen

I have tried with the latest wimboot revision (2.3.0) but to no avail.
Adding vmware drivers to the WinPE wim also has no effect.
I have also tried to modify the number of cores per sockets (2 cores on 1 socket or 2 cores on 2 sockets), it also has no effect on the issue.

Is anyone experimenting the same type of issues?


Thibault Hild
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
wimboot & multicore on esx issues - thild - 2014-09-30 17:12

User(s) browsing this thread: 1 Guest(s)