The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help debugging iPXE EFI kernel boot failure
2014-12-15, 23:02
Post: #1
Help debugging iPXE EFI kernel boot failure
Hello. I've been playing with iPXE on both legacy and EFI mode. I have both working with
chainloading the respective grub.0/grub.efi and that works.

What I really want to do is load the kernel and initrd directly.

I've seen in the forum other people have had success with this on EFI.

I'm using the latest source code (refreshed git a few hours ago).

On legacy systems, everything works fine, the kernel boots, goodness.

On my EFI system, I get no output after "boot" after loading the kernel. I've tried various combinations but on the forum this seems to be the preferred method:

iPXE> kernel tftp:// initrd=initrd console=ttyS1,115200,n8
tftp:// ok
iPXE> initrd --name initrd tftp://
tftp:// ok
iPXE> boot
(then nothing)

I tried enabling earlyprintk in linux but saw nothing. I also connected to the VGA screen and
there is nothing different there either.

If I reset and network boot grub.efi (grub2) instead of ipxe.efi, it works ok - same kernel and initrd.

Any suggestions on how I might debug this problem?

In the mean time, I'll try to find some different kernels to play with.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
Help debugging iPXE EFI kernel boot failure - erikj - 2014-12-15 23:02

User(s) browsing this thread: 1 Guest(s)