The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
kernel boot failure with ipxe on uefi mode
2015-01-14, 09:11
Post: #1
kernel boot failure with ipxe on uefi mode
Hello, I've been trying to load linux kernel and initrd directly with ipxe on uefi mode. The kernel and initrd I have tried are from hp scripting toolkit linux 10.02-1. The ipxe command I've tried as follows:

iPXE>kernel initrd=initrd.img

then it output:
VFS: Cannot open root device "(null)" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
kernel pannic - not syncing:VFS: Unable to mount root fs on unknown-block(0,0)

While I used the same kernel and another initrd from fedora, it worked fine.
I also tried to boot the kernel with pxe directly using bootx64.efi and elilo.conf, it worked fine too. And If I chain bootx64.efi in ipxe command line, it would boot into grub2 command line and then I don't know what to do.
Since I need use the tools in the hp scripting toolkits linux, i have to load the kernel and initrd.img from hp scripting toolkits linux directly.

Is there anyone can help me with this problem?
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
kernel boot failure with ipxe on uefi mode - birkhoff - 2015-01-14 09:11

User(s) browsing this thread: 1 Guest(s)