The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
zlib error
2015-05-21, 20:40
Post: #1
zlib error
I have tried and tried to make this work. I have tried to bypass the need to run make in order to use this program, as running the make command results in an error. I keep getting this error at the end of the make command within the src folder:
[BUILD] bin/hyperv.ids.o
[AR] bin/blib.a
ar: creating bin/blib.a
[HOSTCC] util/zbin
util/zbin.c:7:18: fatal error: lzma.h: No such file or directory
#include <lzma.h>
compilation terminated.
Makefile.housekeeping:1294: recipe for target 'util/zbin' failed
make: *** [util/zbin] Error 1
-end quote

I have all the required dependencies installed and I am trying to run this on a debian jessie install. I have found a few posts about this error from 2012 and it was noted to amend the make command with NO_WERROR=1 but this does not change the result. It still fails.

I have tried to create my own files at and can't get it to work. I am really confused about doing the simplest thing with this program, but I shall keep trying. This is what I would like to do.

A little background - I have a fully functioning PXE server with both the http and tftp daemons, with several grub entries serving up several different systems from both iso files and squashfs files (like gparted). It works fine because I have access to the router running dhcp and I can amend the dhcp.conf file to set the next-server and file information for other systems to boot from. I even created my own live version of debian to pxe boot. Again, it works fine.

Need to do - On another corporate network, I need to use a usb device to point the boot information to a specific ip address on a LAN (and/or WAN), because I will not have access to the router or the dhcp server. Can this be done with iPXE? From reading, and more reading, it seems like it would be easy but I am having no luck at all.

What I have done - I have successfully created a usb boot device with grub installed, and I can boot the ipxe.iso file from it. But from there I am brain locked and can't get past this.

Any help with the error message above and/or a way around this to make it work would be very appreciated. Thank you.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
zlib error - nixer - 2015-05-21 20:40
RE: zlib error - NiKiZe - 2015-06-02, 23:43

User(s) browsing this thread: 1 Guest(s)