Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Ctrl-B not working on Acer Aspire One
2016-02-26, 21:31 (This post was last modified: 2016-02-26 21:41 by mbirth.)
Post: #5
RE: Ctrl-B not working on Acer Aspire One
(2016-02-26 21:21)NiKiZe Wrote:  If you boot undionly.kpxe then it is BIOS Legacy mode not EFI and my best guess then is a broken keyboard Wink

Well, the letter "b" is working just fine when typing in the config menu. My first guess was that it's a problem because this is a German keyboard, i.e. it has an additional key. (KEYBOARD_MAP is set to "de", tried with "us" - no change.) But then there would've been more weird effects, I think.


(2016-02-26 21:21)NiKiZe Wrote:  There is no embeded script, and you still see "Press Ctrl-B for the iPXE command line" message?

Yup. Compiled it with "make bin/undionly.kpxe" without any other parameter. And the prompt shows up after the feature list.

EDIT: Tested it with the prompt command. And funny enough: Ctrl-B seems to be dead to iPXE. However, Ctrl-A (0x01) works just fine, so does Ctrl-C (0x03). I don't know what Acer did to this thing.

EDIT2: I FOUND IT! Seems like Ctrl-B is some kind of magic key or whatever. BUT: If I press Ctrl-Fn-B, it is recognised by iPXE. The Fn-key seems to map the key from "magic" back to normal. Stupid Acer.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Ctrl-B not working on Acer Aspire One - mbirth - 2016-02-26 21:31



User(s) browsing this thread: 2 Guest(s)