Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AMD Hyper-V fails to load iPXE ISO
2016-07-10, 21:14
Post: #2
RE: AMD Hyper-V fails to load iPXE ISO
(2016-04-05 22:07)jeremyherrmann Wrote:  We have 3 Hyper-V Clusters running 2012 R2. Two clusters run Intel Processors and one runs AMD processors. When we try to boot a Hyper-V VM (Gen 1 or Gen 2, Legacy or Standard NIC), the iPXE ISO loads properly. However, when we try the same configuration on the AMD environment it hangs at "iPXE initializing devices....".

We've tried every configuration on the Hyper-V VM that we can think of and we can't get past this. We were able to get a gPXE ISO to boot to a Hyper-V Gen1 VM with a Legacy adapter on the AMD hypervisor.

This may be worked around by

It's a pretty obscure problem: it seems that the emulated RTC interrupt mechanism in Hyper-V is simply broken. The RTC registers show that it is generating IRQ8, but the PIC registers show that nothing is generating IRQ8. Consequently, iPXE locks up waiting indefinitely for IRQ8 to happen. I can't tell if it's a bug in the RTC emulation or a bug in the PIC emulation, and I have no idea why it seems to affect only AMD hardware.

Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: AMD Hyper-V fails to load iPXE ISO - mcb30 - 2016-07-10 21:14

User(s) browsing this thread: 1 Guest(s)