The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iPXE handoff issues
2016-06-01, 00:01
Post: #1
iPXE handoff issues
So to start, I love iPXE, but can't use it.

I started off using gPXE a few months ago to install windows 7 to iSCSI drives on a NAS.

I used a regular windows 7 install disk to install the OS after attempting a sanboot that failed because the iSCSI drive was blank. Then the BIOS did as it should and reverted to the next in the Boot Order which was CD.

Since I used keep-san = 1 then the iSCSI drive stayed mounted and showed up as a local hard drive to the windows 7 installer CD.

I cannot reproduce this ability with iPXE.
I can still boot to windows 7 with gPXE and install on blank iSCSI drives with gPXE.
With iPXE I cannot boot from or install to iSCSI.

There are a lot of features of iPXE that I really want to use, like the built in menu system and the advanced command line and scripting options like using the sanhook command which is new compared to gPXE.

In my experience iPXE has had some issues handing off control of the NIC to other programs.

Example: I can boot gPXE, run dhcp then chain iPXE fine
If I run iPXE, get dhcp then chain gPXE, gPXE cannot obtain dhcp

Example2: I can boot Windows Deployment services fine by itself and install to local drives, but if I chain from iPXE (with all the right gateway hacks) I can ping the iSCSI target and I see the static route to it with the gateway the same as the target. But Windows PE gives the error: "Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk..."

Example3: If I sanhook my iSCSI target, then exit iPXE to drop to CD install, windows PE does not see any NIC interfaces at all.

Example4: I can boot from an iSCSI disk by using sanboot on gPXE, but when I use the same command from iPXE the boot fails to "A disk read error occurred"

It seems like iPXE is not releasing the NIC to the next thing in each of these situations. I know that after a sanhook certain tunnels need to stay open so you don't lose connection to the target, but how come this worked in the past with the last version of gPXE but not anymore?

I really would like to use the new features in iPXE, but if I can't get the basics that are already working in gPXE to work in iPXE then there is no point to move further. I read that windows installation media needs to be modified to allow it to install to an iSCSI disk. Why? It works with gPXE just fine.

Can someone help me?

I am chainloading undionly.kpxe from builtin PXE rom for both gPXE and iPXE. I got these files from the rom-o-matic sites from the tops of the latest builds. I have tried these examples above across various network cards and computer types with consistent results.

Surely the compatibility that gPXE had with regular things like windows install discs shouldn't be lost to introduce new features right? Surely things can't actually be HARDER in iPXE to accomplish than in gPXE right?

If I can't get iPXE to work, I will have to stick with gPXE because that is working, but boy would I like to be able to use the new command line options from iPXE.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
iPXE handoff issues - jbirlingmair - 2016-06-01 00:01
RE: iPXE handoff issues - mcb30 - 2016-06-03, 16:51
RE: iPXE handoff issues - mcb30 - 2016-06-03, 19:59
RE: iPXE handoff issues - mcb30 - 2016-07-12, 05:48
RE: iPXE handoff issues - mcb30 - 2016-07-12, 18:42

User(s) browsing this thread: 1 Guest(s)