The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved][wimboot] Dell Optiplex 7440AIO hangs at startup with UEFI
2016-07-05, 18:48 (This post was last modified: 2016-07-06 19:03 by blanalex.)
Post: #1
[Solved][wimboot] Dell Optiplex 7440AIO hangs at startup with UEFI
I have a new model of computer, Dell Optiplex 7440 All-in-One desktops and they won't boot in WinPE in UEFI mode. In legacy mode, they boot just fine. Other computers boot fine too in UEFI mode. The files download normally and control is passed over to Windows. The Windows splash screen (well, the Dell logo since Windows reads the logo from DMI) appears but there's no "spinner" underneath it and nothing else happens. I have to reset to turn off the computer by holding the power button for a few seconds.

I've tried with 6 or 8 computers of the same model, both with the factory firmware (1.3.7, I think) or the latest available for download (1.4.7). I'm running the current wimboot version (2.5.2) and tried with older versions I have at hand: 2.1.0 and 2.4.1.

The exact same WinPE image boots fine from a USB drive

Here's my iPXE script:
. ($pwd.path + "\common.ps1")
set wimboot-path http://server/wimboot
kernel ${wimboot-path}/wimboot-2.5.2 gui
imgfetch --name BCD               ${wimboot-path}/bcd                BCD
imgfetch --name boot.sdi          ${wimboot-path}/boot.sdi           boot.sdi
imgfetch --name wgl4_boot.ttf     ${wimboot-path}/wgl4_boot.ttf      wgl4_boot.ttf
imgfetch --name segmono_boot.ttf  ${wimboot-path}/segmono_boot.ttf   segmono_boot.ttf
imgfetch --name segoe_slboot.ttf  ${wimboot-path}/segoe_slboot.ttf   segoe_slboot.ttf
imgfetch --name segoen_slboot.ttf ${wimboot-path}/segoen_slboot.ttf  segoen_slboot.ttf
imgfetch --name boot.wim ${wimboot-path}/SCCM-WinPE10-x64.wim        boot.wim


If I add a pause to wimboot I get this:
Command line: "wimboot-2.5.2 gui pause"
Using wimboot-2.5.2 via 0x93b69a48 len 0xa600
Using BCD via 0x93b69ae8 len 0x40000
...found BCD
Using boot.sdi via 0x93b69b88 len 0x3060000
Using wgl4_boot.ttf via 0x93b69d88 len 0xb95c
Using segmono_boot.ttf via 0x93b69e28 len 0x8cb4
Using segoe_slboot.ttf via 0x93b69ec8 len 0x12e5c
Using segoen_slboot.ttf via 0x93b69f68 len 0x12d20
Using boot.wim via 0x93b6a248 len 0x1632a7ad
...found WIM file boot.wim
...found file "\Windows\Boot\EFI\bootmgfw.efi"
Using BOOTX64.EFI via 0x93ae4a00 len 0x11af60
...extracted \Windows\Boot\EFI\bootmgfw.efi
Loaded BOOTX64.EFI
Press any key to continue booting...

EDIT: Solved; switched from snponly.efi to ipxe.efi (all-drivers)
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
[Solved][wimboot] Dell Optiplex 7440AIO hangs at startup with UEFI - blanalex - 2016-07-05 18:48

User(s) browsing this thread: 1 Guest(s)