Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WiFi connection problem
2017-08-22, 14:55
Post: #1
WiFi connection problem

bit of a strange one so far as I can tell. Using the prebuilt binary version and booting from usb all seems well with networking, ifstat returns both hardwire and WiFi adapters as seen and known.

When wired it is possible to bring the interface up as expected.

WiFi adapter is ar9300 [168c:002e]

When using WiFi I repeatedly get 'Connection timed out' after ifopen then ifstat commands entered.

When ifclose-d and trying to iwlist I get the same response - after a pause.

iwstat - when closed as expexted shows 'not associated'

iwstat - when open shows 'associating' and, if iwstat re-run shows same but on a different channel.

All the above is the case whether SSID and key have been entered or not.

It seems that the adapter is there, the drivers are working (at least up to a point) and that the iPXE command line is trying to both see wireless networks and also connect to them but, for reasons unknown, not able to ... ?

From a clean boot when I run iwstat I also have 'antenna off' until I run iwlist which must 'wake up' the antenna because running iwstat after that shows Channel, Signal Quality and rate information.

I'm going to build from the latest git repository a debug iso to see if I can glean any more details but thought I'd check to see if any/all of the above makes sense to anyone or if you've seen/solved previously.
Find all posts by this user
Quote this message in a reply
2017-09-19, 11:06
Post: #2
RE: WiFi connection problem
Yep, building with the appropriate DEBUG=filename,filename for the problematic .c files should yield some more insight.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 1 Guest(s)