The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
486er hangs on boot with iPXE floppy
2017-12-27, 03:23
Post: #1
Heart 486er hangs on boot with iPXE floppy
Dear community,

I have restored my 486 DX2-66 MHz machine utilising 24 MB of RAM to work perfectly fine again, like back then.

Now I've came to the idea, why not use it's capabilities to forensically restore floppy disks, specifically reading from 5,25" and 3,5" drives saving stuff to a NAS.
Also for creating images of internal drives it would be nice to have something similar to dd or partimage.

Very nice, you may think.. boot off a 32bit CD and be a happy man. - Unfortunately the BIOS does only offer the boot options "A, C" and "C, A", which kind of limits my options to booting off a floppy disk.

I've tried SuSE 6.0, as I had this flying around still, and it works.. but not as good as it could. It is also a security risk to have such a thing running on the network, as there are no updates anymore.
For any newer version the kernel was too big to fit on a 1,445 MB floppy, and therefore I needed to dig deeper: Slackware Linux has the same problem... reasonable version numbers have a wayyy too big kernel to boot from a 3,5" floppy.. but the Slackware guys had a nice idea.. why not use PXE? - Just go ahead and write a floppy, boot from a network stored image, and magic surrounds the whole thing.

In theory this should have worked, BUT.. for starters the 486er boots quite nicely from the floppy disk showing:

Quote:Loading ROM image...................................

... but then freezes and never goes any further. - What might that be?
I have tried this floppy on all the other machines here and at work that have 3,5" floppy disk support.. and it works on all the other machines, even on VirtualBox, but not on the target machine..

Any ideas?
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
486er hangs on boot with iPXE floppy - His_Cifnes - 2017-12-27 03:23
What if... - His_Cifnes - 2018-01-04, 00:23
RE: What if... - NiKiZe - 2018-01-04, 00:41
test finished. - His_Cifnes - 2018-01-09, 22:36

User(s) browsing this thread: 2 Guest(s)