Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
android-x86 pxe boot
2018-12-15, 07:39
Post: #4
RE: android-x86 pxe boot
(2018-07-10 18:47)ayx Wrote:  Hello @MultimediaMan thanks a lot .. yes you are right i was not downloading the ramdisk.img .
after downloading it the "detecting android ...." stage got solved .. here is my iPXE script


echo Hi, trying to boot androidx86
set server_ip
set nfs_path /home/ayx/android-x86/out/target/product/x86_64
kernel nfs://${server_ip}${nfs_path}/kernel || read void
initrd nfs://${server_ip}${nfs_path}/initrd.img || read void
initrd nfs://${server_ip}${nfs_path}/ramdisk.img || read void
imgargs kernel root=/dev/nfs rw ip=dhcp androidboot.hardware=android_x86_64 netboot=nfs nfsroot=${server_ip}:${nfs_path},nolock,wsize=4096,rsize=4096 initrd=initrd.img,ramdisk.img ROOT=${server_ip}:${nfs_path}
boot || read void
echo Booting

but now i have got a new problem ... the booting gets failed by showing "/system/bin not found" .. actually there are several system paths shown not to be found . in the end the booting is stuck at showing "binder 1756:1756 transaction failed ..... "

do i need to modify the init script or code at the source and build again ?.maybe the rootfs is failing to get mount over nfs ?

thanks for the help.

I am also facing same issue "binder 1756:1756 transaction failed ..... ".
can you please help me if issue is solved for you.

Sk shahul.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
android-x86 pxe boot - ayx - 2018-07-08, 20:31
RE: android-x86 pxe boot - ayx - 2018-07-10, 18:47
RE: android-x86 pxe boot - shahul - 2018-12-15 07:39

User(s) browsing this thread: 1 Guest(s)