Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Loading PNG for console on older hardware broken
2018-08-15, 23:03
Post: #5
RE: Loading PNG for console on older hardware broken
(2018-08-09 22:47)NiKiZe Wrote:  Please run it with the debug build.
If possible it is good to get the data so that we can figure out what have gone bad. And also help others that might see this in the future.

If we don't get anything from the debug output then running a bisect to find out exactly when this broke would be extremely helpful


Tried a debug build but got no additional error messages than what I was getting before.

Using double pipes did address my issue and allows the menu to fall back to using text mode which is fine.

I also gave the git bisect a try but was not able to build a working version of undionly.kpxe, even with the version I thought I had used. I am not sure if this problem might be related to the fact that I upgraded my build box from Ubuntu 17 to 18. I might try again with a fresh build environment in the future.

One additional thing that I did at the iPXE command line is this:

console -x 800 -y 600

Gives me the "could not configure console: No such file or directory" error. But:

console -x 640 -y 480


When it errors out, it returns to a 720x400 resolution. But trying the console command with that resolution will also result in an error.

I tried several more times with 800x600 and it jumped to 1024x768. This is really all over the place.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Loading PNG for console on older hardware broken - pxe_curious - 2018-08-15 23:03

User(s) browsing this thread: 2 Guest(s)