The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Intel X710 not working once WIM is loaded with WIMBOOT
2018-08-17, 23:22
Post: #1
Intel X710 not working once WIM is loaded with WIMBOOT
Testing with a Dell PowerEdge R640 in UEFI mode and the X710 rNDC.

Loading iPXE and then WIMBOOT then WinPE based on Windows 10 1803 (and also tried 1607 and 1709).

Using the following iPXE script:
imgselect ${ks-ipxe-url}/win/wimboot gui
imgfetch --name bcd                ${ks-ipxe-url}/win/bcd                       bcd
imgfetch --name boot.sdi           ${ks-ipxe-url}/win/boot.sdi                  boot.sdi
imgfetch --name segmono_boot.ttf   ${ks-ipxe-url}/win/fonts/segmono_boot.ttf    segmono_boot.ttf
imgfetch --name segoe_slboot.ttf   ${ks-ipxe-url}/win/fonts/segoe_slboot.ttf    segoe_slboot.ttf
imgfetch --name segoen_slboot.ttf  ${ks-ipxe-url}/win/fonts/segoen_slboot.ttf   segoen_slboot.ttf
imgfetch --name wgl4_boot.ttf      ${ks-ipxe-url}/win/fonts/wgl4_boot.ttf       wgl4_boot.ttf
imgfetch --name boot.wim           ${ks-installs-url}/windows/pxeboot/${winpe}  boot.wim
The above script works completely fine for all the hardware I have and the WinPE WIM gets successfully loaded even on with the X710 card.

But with the X710 card, once it has been loaded, I am not able to get a link. It appears to be flapping constantly. Doing a netsh int show int does show the interface to be connected and then disconnected and it just keeps going like that. TCP/IP is trying to get a DHCP address but keeps falling back to an APIPA because the communications with DHCP server never completes. I have tried wpeinit and other means to reset the NICs within WinPE, but nothing changes.

I thought it might be a driver issue, but was able to confirm that the WIM I am loading works perfectly fine when loaded from a USB drive, network and all.

So the only pointer I have is that it doesn't work when loaded via iPXE/WIMBOOT.

Other network cards do not show this issue, including Intel X550s and so on.

The X710 has no problem with iPXE and other operating systems. I am able to install various Linux OSes, VMware, etc. I am using the snponly.efi binary.

So what i am wondering:
- is it something with my BCD? Are there options I am missing? Should I reserve some memory area or block it off? (I compared the BCD I use with the one that comes of the Windows install media, nothing jumps out.)
- Is snponly.efi putting the NIC into an unsupported mode or hanging onto memory when it shouldn't?
- Is WIMBOOT holding onto something? (I read the WIMBOOT page again and it does state that WIMBOOT releases all the memory.)

I saw a couple of threads about the X710, but I am not having an issue with iPXE loading or WinPE hanging on boot up. My issue specifically is that once WinPE has loaded and correctly identified the devices and loaded the correct drivers, I am not able to establish a network connection and the link appears to be flapping (but mostly showing as disconnected).

I am using the latest build of WIMBOOT, version 2.6.0. My snponly.efi is based on commit d2063b7693e0e35db97b2264aa987eb6341ae779.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
Intel X710 not working once WIM is loaded with WIMBOOT - pxe_curious - 2018-08-17 23:22

User(s) browsing this thread: 1 Guest(s)