Post Reply 
Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] iPXE won't boot on old Pentium
2019-02-09, 15:04 (This post was last modified: 2019-02-13 00:53 by xavquatorze.)
Post: #1
[SOLVED] iPXE won't boot on old Pentium
I'm trying to load iPXE on an old P233MMX but the boot process gets stuck after.
Loading ipxe.krn.......ready.
No Ctrl-alt-del, I've to hard reset.

I've tried :
- the official iso (isolinux loads but no iPXE)
- build on WSL (Ubuntu 18.04)
- build on Debian 9 i386
With the same result, with floppy image and iso.

I've tested a build with debug enabled :
make bin/rhine.iso DEBUG=libprefix,dskprefix

iPXE ISO boot image
Loading rhine.krn... ok

install_prealloc: 00009C88 00009D0C 00000000 00000000 FFFFFFFF
   .text16.early  00010DF0 0009C080 000000F8 000000F8
   open_payload   00000000 00000EE0
   .text16.late   00100000 0009C980 00000712 00000712
   .datal6        00100570 0009D0C0 000000C0 000000C0
   .textdata      001005C0 04052000 0001BB10 0009DD68
   init_librm     00009C88 00009D0C 04052000

If the boot process worked, the next message should be

From the source I understand that it has to do with switching to protected mode. So I tried to build a kir with
make -f arch/i386/kir-Makefile
but failed :

What can I do next?
Find all posts by this user
Quote this message in a reply
2019-02-13, 00:52
Post: #2
RE: iPXE won't boot on old Pentium
Well, after several trial and error, undefining TIVOLI_VMM_WORKAROUND in general.h does the trick.
Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 1 Guest(s)