Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iPXE boot 3Com PCMCIA card
2019-04-11, 21:19
Post: #1
iPXE boot 3Com PCMCIA card
Hello again, dear forum! : )

I`ve got two Panasonic Toughbooks CF-M34 mark 1, as out company would have thrown them away elsewise.

Since they are in perfect state still, I decided to dispose them myself in person. ; )
The Toughbooks unfortunately allow only to boot from A: or C:. Also ths thing has no ethernet port, same goes for the docking station, that I aso have.

Okay, so far so good.. I can boot from floppy, which means I could iPXE boot some boot media, so I thought, but since this hardware has no ethernet port, I need to use the PCMCIA port. Now I have three PCMCIA LAN cards.. a Highscreen one, a Xircom one and a 3Com. According to the [iPXE device list] the 3Com and Xircom cards are the most promising ones.
Unfortunately none of the cards does work with the latest iPXE boot image. :/

Question is, is there a way to enable PCMCIA support and make a 3Com 3C589D Combo card work with iPXE?

I`d like to boot CloneZilla first, to image the current HDD status, and then, after this, I`d install either [ArcaOS] or OS/2 Warp. - Maybe even Windows 2000.

Thanks in advance for reading : ))
Find all posts by this user
Quote this message in a reply
2019-04-11, 21:23
Post: #2
RE: iPXE boot 3Com PCMCIA card
Ok, so my PCMCIA skillz are "a bit" rusty...
you should, as usual, try to get pciid from them, if they are pci based devices.
With any luck they could be initialized by BIOS.
If however there is bridges that needs to be enabled, then that might be hard to get up n running.

Use GitHub Discussions
VRAM bin
Visit this user's website Find all posts by this user
Quote this message in a reply
2019-04-13, 11:01
Post: #3
RE: iPXE boot 3Com PCMCIA card
Whoah, NiKiZe, thanks for the ultra quick answer.
I`ve tried around a bit, but asking myself how to find out about the PCI ID.

So far I have tried lspci with linux. But even in verbose mode, I am unsure which number is the one in question.

Also even when the PCMCIA card is fully operable (got an IP from dhcpd), it is only listed @ lsmod, but not at lspci... just the PCMCIA slots appear @ lspci. - I have tried all three cards, but same with all three of them.

Which method do you suggest to find out about the PCI ID?
Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 1 Guest(s)