Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
IPv6 only iPXE
2019-07-10, 22:14
Post: #1
IPv6 only iPXE
Hello iPXE community!

I've been working on a project to use iPXE with IPv6 only. While it does work, I still have a small issue.

The problem is that iPXE will, by default, try IPv4 DHCP first and after DHCP_DISC_END_TIMEOUT_SEC (which can be 10 to 32 seconds depending on the linux distribution) it will try SLAAC/DHCPv6.

I have tried to #undef NET_PROTO_IPV4 but unlike NET_PROTO_IPV6, that doesn't seem to do a single thing. As a workaround, I have modified DHCP_DISC_END_TIMEOUT_SEC to 1 second, which is acceptable.

But nonetheless, it should be possible to disable IPv4 or at least make it possible to disable the default DHCPv4 at initialisation.

I could write a patch, but I'd like to have some comments on which is the most appropriate way to disable this. I have never worked in the community, so please guide me a bit and let me know which would be an appropriate patch to achieve an acceptable "IPv4 disabled" state.

My personal opinion is that disabling DHCPv4 at initialisation should be sufficient. After that, I don't mind if the iPXE user wants to download a script that does DHCPv4. The annoying part is when you're not yet in control.

What do you think?
Find all posts by this user
Quote this message in a reply
2019-07-13, 14:49
Post: #2
RE: IPv6 only iPXE
You should probably register on the mailing list, and send an email there (unless you already have done so)

Use GitHub Discussions
VRAM bin
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 1 Guest(s)