Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lenovo Drive Erase Utility + UEFI + IPXE
2019-07-31, 15:46 (This post was last modified: 2019-07-31 15:47 by thehumm.)
Post: #3
RE: Lenovo Drive Erase Utility + UEFI + IPXE
(2019-07-24 17:22)NiKiZe Wrote:  How have you tried to load them? how does the relevant part of iPXE script look like that you have tried?

If you remove the .exe file from the USB device and test, what happens then?

Hi NiKiZe,

Thanks for the reply! Sorry I did not respond sooner, I got busy with some other tasks in the past week. So in coming back to this, here is what I am seeing:

If I use this to boot from iPXE in my menu.ipxe then I just get a black screen after it loads. It also will respond to control alt delete and reboot, so it is not frozen per say:

echo Booting ThinkPad Drive Erase for ${initiator-iqn}
set root-path ${base-iscsi}:${hostname}.boot.freedos
set base-url http://myserver/techtools/Both/ThinkPadDriveErase
imgfetch ${base-url}/BootX64.efi
boot BootX64.efi || goto failed
goto start

If I take the exe off of the USB it also loads, so this suggests everything should be within the BootX64.efi file. It sounds like I just need some help figuring out how to load this particular EFI file I am guessing.

The structure on the USB is: /EFI/Boot/BootX64.efi
It is FAT32 formatted

I've tried using initrd instead of imgfetch or kernel and so far no luck. Any suggestions?
Thank you very much in advance!
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Lenovo Drive Erase Utility + UEFI + IPXE - thehumm - 2019-07-31 15:46

User(s) browsing this thread: 1 Guest(s)