Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FTP chainloading a menu.ipxe
2019-09-18, 02:19
Post: #3
RE: FTP chainloading a menu.ipxe

> ftp, no username or password are provided.

It's not a problem, I compiled ipxe with FTP debug enabled and it connect anonymous (user: anonymous , pass:

I've tested with password and it function as well:

initrd http://ftp.user:pass@192.168,0,254/Disque%20dur/rootfs.gz
kernel http://ftp.user:pass@192.168,0,254/Disque%20dur/bzImage64

> make sure that you really intent to use FTP and not TFTP.

Nope... Really FTP.

> Are you sure that you get a full hang, and not a error message of any kind? Have you tried running this from a shell, that is not using an embded script - which should always be what you test first before embedding (that is trying the basic parts in shell by typing it out)

It don't hang, PC just reboot, no error message or no time to read.
Yes, I tried from shell.

EMBEDed script:

chain http://ftp.

menu.ipxe (for testing):


Also I can't do SANHOOK or SANBOOT with FTP.

Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: FTP chainloading a menu.ipxe - alhyene - 2019-09-18 02:19

User(s) browsing this thread: 1 Guest(s)