Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
boot and install windows server
2020-03-30, 17:21 (This post was last modified: 2020-03-30 17:55 by bluedark.)
Post: #1
boot and install windows server
Hi all,
My ipxe system works wonderfully except one point : the boot on a windows server 2019 works well but before the installation, it tells me that it misses the media driver.
When I boot a hyper-v virtual machine in ipxe on the same windows server 2019 but having added the iso of the dvd, it works well.
The question is: how to boot the vm in ipxe and be able to install windows server 2019 without being able to add the iso of the dvd (if I am remote and that I can't add it in the vm)?
Thank you !

for info (maybe important), my machines are in uefi
Find all posts by this user
Quote this message in a reply
2020-04-07, 12:28
Post: #2
RE: boot and install windows server
no one to help me?
Thanks!
Find all posts by this user
Quote this message in a reply
2020-04-20, 10:35
Post: #3
RE: boot and install windows server
UP
thanks !
Find all posts by this user
Quote this message in a reply
2020-06-16, 09:19
Post: #4
RE: boot and install windows server
You need to find which driver(s) you need to make it work. Then add them to your boot.wim that you are already using for booting WinPE.
Find all posts by this user
Quote this message in a reply
2020-07-14, 14:10
Post: #5
RE: boot and install windows server
Hello
thank you for the reply.
I added the drivers to boot.wim, but I still can't see my hard drives.
I tried on 3 different computers ...
and even trying to load them manually, it doesn't work ...
How is it that it works well with a dvd or a usb stick, but not in pxe?
Thank you in advance!
Find all posts by this user
Quote this message in a reply
2020-07-15, 20:25
Post: #6
RE: boot and install windows server
I tested with windows 10 and windows 7, same problem ...
With a DVD, when I load the driver it works, so I have the right drivers.
In my config, I launch the bcd file, then boot.sdi, then boot.wim.
Can you help me?
Thanks
Find all posts by this user
Quote this message in a reply
2020-07-16, 23:48
Post: #7
RE: boot and install windows server
I haven't played with Hyper-V in a while...

However, and this may or may not help, but in ESXi I always have to use IDE mode for the hard drive to be visible to the WinPE installer. Give it a shot in Hyper-V.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)