Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Stuck on initialising devices
2020-05-12, 05:24
Post: #1
Stuck on initialising devices
Hi!
I have problem with initialising iPXE when i boot this from Grub2 menuentry:
Code:
menuentry "WinPE" {
  linux16 (tftp)/ipxe.lkrn
  initrd16 (tftp)/boot/pxe/boot.ipxe
}

Grub2 is booted over the TFTP and invoke the iPXE kernel to load in a chain to load the WinPE.

I compiled the iPXE in debug mode and found that the freeze occurs at the PCI bus stage.
I also found that iPXE is loading if I disconnect SATA drives.

Can you help me to resolve this problem?
Find all posts by this user
Quote this message in a reply
2020-05-14, 05:50
Post: #2
RE: Stuck on initialising devices
output of lspci -nn (linux command)
Grab all lines that has "Ethernet" on them, or just take the whole bunch so that we can see your PCI layout.

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2020-05-14, 12:05
Post: #3
RE: Stuck on initialising devices
Code:
00:00.0 Host bridge [0600]: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register [8086:0f00] (rev 0e)
00:02.0 VGA compatible controller [0300]: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display [8086:0f31] (rev 0e)
00:13.0 SATA controller [0106]: Intel Corporation Atom Processor E3800 Series SATA AHCI Controller [8086:0f23] (rev 0e)
00:14.0 USB controller [0c03]: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI [8086:0f35] (rev 0e)
00:1a.0 Encryption controller [1080]: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine [8086:0f18] (rev 0e)
00:1b.0 Audio device [0403]: Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller [8086:0f04] (rev 0e)
00:1c.0 PCI bridge [0604]: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 1 [8086:0f48] (rev 0e)
00:1c.1 PCI bridge [0604]: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 2 [8086:0f4a] (rev 0e)
00:1c.2 PCI bridge [0604]: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 3 [8086:0f4c] (rev 0e)
00:1c.3 PCI bridge [0604]: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 4 [8086:0f4e] (rev 0e)
00:1f.0 ISA bridge [0601]: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit [8086:0f1c] (rev 0e)
00:1f.3 SMBus [0c05]: Intel Corporation Atom Processor E3800 Series SMBus Controller [8086:0f12] (rev 0e)
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 11)
Find all posts by this user
Quote this message in a reply
2020-05-14, 15:26
Post: #4
RE: Stuck on initialising devices
Another thing that you probably should try is, first of course to make sure you are using the latest version of iPXE.
But you should also try to boot it directly from a USB stick, both grub and syslinux are known to have caused issues in the past.

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2020-05-15, 13:34
Post: #5
RE: Stuck on initialising devices
Quote:Another thing that you probably should try is, first of course to make sure you are using the latest version of iPXE.
But you should also try to boot it directly from a USB stick, both grub and syslinux are known to have caused issues in the past.

Yes, I use last version from http://boot.ipxe.org/

ipxe.usb work properly.

As I wrote above, iPXE also boots through the grub if I disconnect the SATA disks.

I use the following boot chain order:
PXE -> DHCP
filename "boot/grub/i386-pc/core.0" from TFTP
grub.cfg from TFTP
ipxe.lkrn from TFTP
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)