Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MemTest86 UEFI not sending reports to TFTP when Started By iPXE
2020-05-14, 09:29
Post: #1
MemTest86 UEFI not sending reports to TFTP when Started By iPXE
I am hopping that I missed something obvious but I think its a limitation of IPXE. I am unable to save MEMTEST reports to TFTP when MEMTEST is started using IPXE.

If MEMTEST is run by efi pxe boot pointing at the memtest efi file in DHCP its able sends to send reports to the TFTP server. But if MEMTEST is started using IPXE it's unable to send the report to TFTP.

When starting MEMTEST using IPXE I can see that its able to get files from TFTP but not put.

For example then MEMTEST is started by IPXE I can see that pulls down the config file and then you try to save the report MEMTEST pulls down the header file and footer file as part of generating the report. But the report is not uploaded.

Any ideas?
Find all posts by this user
Quote this message in a reply
2020-05-14, 15:30
Post: #2
RE: MemTest86 UEFI not sending reports to TFTP when Started By iPXE
You probably need to figure out what memtest are using in terms of efi calls and then try to debug that, but hey, why not contact memtest about it?

are you using ipxe.efi or snponly.efi
and have you tried the other one of them, and does that behave identically?

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2020-05-14, 23:29
Post: #3
RE: MemTest86 UEFI not sending reports to TFTP when Started By iPXE
Hi NikiZe

To answer your first question here is a quote from memtest86.com/tech_pxe-client-config.html

There is a known issue with using the iPXE open source network boot firmware to chainload the MemTest86 UEFI image. Because iPXE does not support TFTP uploads, report files cannot be saved to the TFTP server. However, the mt86.cfg configuration file can still be downloaded from the TFTP server.

To your second question I have been using ipxe.efi but before posting this I complied snponly.efi and it behaves the same way.
Find all posts by this user
Quote this message in a reply
2020-07-01, 03:10
Post: #4
RE: MemTest86 UEFI not sending reports to TFTP when Started By iPXE
I was about to ask the same question as this, as my company is going to be using memtest86 and would like to be able to upload the reports from it however was told the same thing that the upload features are not implemented yet. If there is anything I can do to help with this I will gladly help out. I have some knowledge of doing some C++ but not much C.
Find all posts by this user
Quote this message in a reply
2020-09-24, 19:49
Post: #5
RE: MemTest86 UEFI not sending reports to TFTP when Started By iPXE
Were you able to ever solve this issue? I have the same issue that I am trying to figure out the best way of fixing it without having to switch to a windows server with Serva and use basic pxe booting.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)