Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iPXE ignoring DHCP ACKs
2011-05-12, 15:20 (This post was last modified: 2011-05-12 15:22 by electronsrock.)
Post: #3
RE: iPXE ignoring DHCP ACKs
(2011-05-12 09:25)robinsmidsrod Wrote:  I'm not sure what is going on here, since I don't use VLAN features at all, but if you provide the packet trace (create an attachment) someone else might be able to help you out.
After you have done the DHCP command and seen it time out, you should provide the full output from the ifstat command, to verify how many packets have been sent and received. It is also useful to specify how you load iPXE (chainloading, rom-burned, usb/cd/floppy-loaded) and which network card you're using (VENDOR+PCI ID). If you have multiple network cards in the machine, that could also be relevant.

Almost forgot; which version/commit of iPXE are you using?

Thanks for replying. I'll work on exporting the trace, though my company is a bit paranoid about this stuff so it could take some time. The most frustrating thing is that this exchange USED to work, so it might be some change in our network, but for the life of me I can't find any changes.

The first thing I did was disable VLAN tagging to make sure it wasn't messing anything up. I've used both chainloading and boot CD in the past, both have worked. As a test for hardware failure, I used the trusty boot CD that has always worked on another machine with identical hardware, still doesn't work now. I'm seeing tons of repeated DHCP packets from the client and he's ignoring the ACKs I'm seeing him receive. He must eventually receive a DHCP OFFER from the server he likes because he does eventually send (10) REQUESTS. And once in a blue moon, like once every 25 reboots, he takes the IP. Once in a while, he likes the ACK he's receiving or it comes fast enough (like I said, I have no idea if DHCP requests time out and how often).

The worst part is that the Intel PXE bootloader works just fine, does a perfect DHCP request (since I disabled VLAN tagging, I was able to test using the default Intel program).

The network card in question is an Intel 8086:105e and I was using a version from a couple months ago (ipxe-HEAD-72d387e) but now I'm using the latest version of iPXE, just captured it from the source and built it yesterday.

It's just so frustrating when something used to work, and then just doesn't, you know?

Is there some way I can control the details of how iPXE sends DHCP requests? The options it uses?

Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: iPXE ignoring DHCP ACKs - electronsrock - 2011-05-12 15:20

User(s) browsing this thread: 1 Guest(s)