The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error





Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CentOS 8 kernel cannot be started from UEFI iPXE
2020-10-08, 16:17
Post: #1
CentOS 8 kernel cannot be started from UEFI iPXE
Hello,
I have spent the past week getting to know the iPXE project and have been familiarizing myself with chainloading iPXE and then installing things over the network. I have been able to do this without issue for Debian 10, but now I ran into severe issues during the past 3 days trying to install CentOS 8.

My setup is as follows:
- RPi4 running pios arm64v8 as DHCP / TFTP / DNS / HTTP server
- Intel NUC10i5FNH2 as the testing machine
- Ubuntu Tower PC as my workstation

I am chainloading into the iPXE binary over tftp. Everything is using UEFI exclusively, SecureBoot is turned off. I embed a script into the iPXE binary that contains this code for booting CentOS:

initrd http://mirror.centos.org/centos-8/8.1.19...initrd.img
kernel http://mirror.centos.org/centos-8/8.1.19...ot/vmlinuz
imgargs vmlinuz initrd=initrd.img inst.repo=http://192.168.178.2/centos8
sleep 2
boot ||

However when I run this immediately get an error saying:
- exit_boot() failed!
- efi_main() failed!

Unfortunately I have no idea what to do here. I searched the forum and google, but have not found a solution. Does someone here have an idea of what is wrong here? I have spent way too much time on this already without making any progress...

Thank you for your help.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
CentOS 8 kernel cannot be started from UEFI iPXE - jhamann - 2020-10-08 16:17



User(s) browsing this thread: 2 Guest(s)