The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iPXE detecting NICs from USB, but not from HDD
2012-12-27, 22:52
Post: #1
Question iPXE detecting NICs from USB, but not from HDD
i'm trying to boot iPXE from grub2, so that i do not have to press F8 everytime i want to start my PC from the network.
I can't get ipxe to detect my NIC, if i start it from grub2. The same version from a usb-stick is working and detecting my NIC.
Whats the differecne? On my Laptop ipxe from grub2 works.

I tried the following setups:
1. installed "grub-ipxe" in Ubuntu 12.10 -> ipxe showed up in grub2
- worked on my laptop
- does not work on my desktop pc (doesn't detect the NIC) - Error EC8 - PXE-Structure not detected

2. tried manual entry in grub
linux16 /boot/ipxe.lkrn
same as above, even with fresh compiled (latest git) ipxe.lkrn or a pxe.lkrn from a new ipxe.iso

3. ipxe.iso on a usb-stick with "unetbootin"
with unetbootin i created a bootable usbstick with ipxe. It worked out of the box and ipxe detected my NIC.
What can I do to have ipxe working from HDD?
Thx in advance

Mainboard: Asus P5K Infos
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
iPXE detecting NICs from USB, but not from HDD - Solo0815 - 2012-12-27 22:52

User(s) browsing this thread: 1 Guest(s)