Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows Server 2012 R2 iSCSI boot
2015-04-10, 19:52
Post: #1
Windows Server 2012 R2 iSCSI boot
Attempting to boot Windows from iSCSI target. I was able to successfully do it on an older laptop to validate proof of concept, but on this board and this board, I've been unsuccessful. Both Windows 7 Ultimate and Windows Server 2012 R2 install fine onto the iSCSI target, but reboot after the first startup (after sanboot).

Here's what I'm doing:
I have windows installation media on USB, boot order set PXE then to USB.

PXE Boot iPXE (chain) with iSCSI support
!#ipxe
dhcp
sanhook iscsi:<ip>:::<lun>:<iqn>
sanboot --no-describe --drive 0x81

It then skips to the next medium in the boot order (USB), and runs the windows installer. I then install windows onto the iSCSI target. On the svme1908, I have to load network drivers in Windows 7 before the iSCSI target presents itself as an install target, but on the C163, I don't. Window Server 2012 R2, no drivers are required, the target shows up fine.

Installation goes fine.

First reboot, I escape into the iPXE prompt and do:
dhcp
sanboot iscsi:<ip>:::<lun>:<iqn>

And it boots into the Windows logo, and eventually BSODs (both Win7 and Server 2012 R2)

I'm thinking I have the same woes as this thread - could it be because these boards each have 4 network ports, and the iBFT isn't being properly populated? The test laptop that worked had only one NIC.

Any ideas what I should try next? Hopefully something stupid and obvious.

Patrick
Find all posts by this user
Quote this message in a reply
2015-04-13, 17:28
Post: #2
RE: Windows Server 2012 R2 iSCSI boot
(2015-04-10 19:52)paquetp Wrote:  First reboot, I escape into the iPXE prompt and do:
dhcp
sanboot iscsi:<ip>:::<lun>:<iqn>

And it boots into the Windows logo, and eventually BSODs (both Win7 and Server 2012 R2)

What is the BSOD?

Are you using undionly.kpxe or a native iPXE driver (e.g. ipxe.pxe)? Have you tried the other?

What are the IP addresses of the initiator and target, and have you tried the "set net0/gateway 0.0.0.0" hack yet?

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
2015-04-14, 18:42
Post: #3
RE: Windows Server 2012 R2 iSCSI boot
(2015-04-13 17:28)mcb30 Wrote:  What is the BSOD?

INACCESSIBLE_BOOT_DEVICE (7B)

(2015-04-13 17:28)mcb30 Wrote:  Are you using undionly.kpxe or a native iPXE driver (e.g. ipxe.pxe)? Have you tried the other?

I tried make bin/ipxe.iso - burn, CD boot.
I tried make bin/unionly.kpxe, pxe boot.
I tried make bin/ipxe.pxe, pxe boot.

No difference in each.
(2015-04-13 17:28)mcb30 Wrote:  What are the IP addresses of the initiator and target, and have you tried the "set net0/gateway 0.0.0.0" hack yet?

No router. Directly attached cable. Initiator is 192.168.2.9, target is 192.168.2.104. Gateway was 192.168.2.104, but I still tried the set net0/gatway 0.0.0.0, but no change.

I'm stumped. I can get it to work on an older laptop with only one NIC - does that help?

FWIW - you guys are doing some amazing things.
Find all posts by this user
Quote this message in a reply
2015-04-17, 19:01
Post: #4
RE: Windows Server 2012 R2 iSCSI boot
(2015-04-14 18:42)paquetp Wrote:  I'm stumped. I can get it to work on an older laptop with only one NIC - does that help?

Difficult to say what might be the problem. It could be related to the multi-port NIC. The iBFT has a design assumption that each Ethernet device corresponds to a single PCI bus:dev.fn, and anything which doesn't fit into that model (e.g. multi-port NICs attached to the same PCI bus:dev.fn, or NICs where the drivers support iSCSI offload) can break because this simplistic assumption is incorrect.

If you are in a position to attach a Windows kernel debugger, then the output from "!devnode 0 1" after the BSOD occurs would be useful.

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
2015-04-23, 20:19
Post: #5
RE: Windows Server 2012 R2 iSCSI boot
The things below is from my experience with AoE and other things and not iSCSI so it might be non issues, but maybe worth trying.

2 things that need to work when the windows kernel takes over from ipxe is that the network driver have been loaded and started and that the iscsi service is started.

It could be that the driver is installed in winpe but not installed in the actual image before first reboot, or that the start mode for the service is not 0.

Maybe double check that drivers are installed in the second stage of installation by installing to local storage and using Shift+F10 to bring up compmgmt.msc
Another alternative is to use dism and force install the drivers into install.wim

Use GitHub Discussions
Visit this user's website Find all posts by this user
Quote this message in a reply
2015-05-07, 13:53
Post: #6
RE: Windows Server 2012 R2 iSCSI boot
Usually ipxe doesn't see other than one lan. So this seems you have to disable ewf driver valve in registry. And service set to start. You can refer reboot.pro. Multiple lan is not a problem.
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)