Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2015-09-30, 13:22
Post: #1
INACCESSIBLE_BOOT_DEVICE after the first reboot win7/8/10

There is a home network with tp-link a router, the server on base дебиан
Described below actions were done on the i5 computer with realtek Gb by the adapter on old intell atom netbook
The task - will arrive Barebone intell pentium based TVBOX soon, I want to load it on ISCSI
I created on debian server ( iSCSI disk

Option 1.
I connected ISCSI a disk to personal computer Windows, with the help of UltraISO Windows 7/8/10 on this disk unpacked an image and the BOOTICEx64 program prescribed it MBR
On the site made an USB image with a script

set netX/gateway
sanboot iscsi:

Installation when asked to choose language and keyboard layout went, pressed Shift+F10, further in the opened window gathered Drvload x:\drvlan.inf (a way to drivers of the network interface card).
Then I wrote Wpeutil InitializeNetwork.
Then the installer saw a disk and copying of files began
After the first reset Windows thinks 3 minutes and stops with a mistake INACCESSIBLE_BOOT_DEVICE

Option 2.
I downloaded Windows Assessment and Deployment Toolkit (ADK) for win 7/8/10, I pulled out from it WinPE, I put it on, also there I put the last wimboot
I created USB with a script

set netX/gateway

set netX/gateway
sanhook iscsi:
kernel wimboot
initrd amd64/media/Boot/BCD BCD
initrd amd64/media/Boot/boot.sdi boot.sdi
initrd amd64/media/sources/boot.wim boot.wim

WinPE was loaded, I try to give command
net use \\\install - error, though the network is also passes a ping
I unpacked iso image Windows on USB, connected to winPE and wrote
cd g:

Installation, but after the first loading again went INACCESSIBLE_BOOT_DEVICE

I tried such to do on two PC about Windows 7/8/10 - the result is identical

Where I make a mistake?
Find all posts by this user
Quote this message in a reply
2015-09-30, 15:33
Post: #2
I'm having the same problem and was actually just about to post a new thread about this. I'm attempting to install Windows 10. Here's what's happening:

- iPXE loads & hooks to my iSCSI target (which is tgtd running on linux server)
- WinPE boots
- I map a drive to a shared copy of the Windows 10 installation, as S:\
- Run S:\Setup.exe
- Setup runs, detects my iSCSI drive, and the first stage of the installation works fine.

When the first stage of Windows setup is complete, but before the first boot:

- I change my pxe script to use sanboot instead of sanhook

First boot:

- iPXE loads & boots my iSCSI target. The Windows 10 boot screen with the animated circles appears.
- About 5 seconds into the boot, my LEDs go dark on my network interface and never come back on.
- The Windows 10 boot screen still shows with the animated circles. This stays up for about 8 minutes or so, then I get the INACCESSIBLE_BOOT_DEVICE error.

I've tried both undionly.kpxe (chainloaded from dhcp) and ipxe.usb (from a usb stick) and I get the same results. I've also

The network adapter is a Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC.

Here's my iPXE boot script:

set net0/gateway # <-- I've tried this with and without, same results.
sanhook --drive 0x80 iscsi:wopr.localdomain:::1:iqn.2015-09.localdomain.wopr:win10.boot

It's almost like Windows is initializing the driver for the network card and it's killing the iSCSI connection, but that's just a guess. Anyone have any suggestions? I'm so close to getting this working!!!
Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 1 Guest(s)