Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No such file or Directory (2d0c613b)
2015-11-10, 13:21
Post: #1
No such file or Directory (2d0c613b)
Hi everyone!

I'm new to this, so bare with me ^^ I work mainly with SCCM and MDT and I'm currently looking into a new solution for a customer. (Only proof of concept at this stage).

I have a Server 2012 R2 installed with DHCP, DNS and IIS 8.
On the IIS I've created a new website with the name "Customer", the binding on this is set to and I can browse it from the server.

There is a virtual directory under this site called "winpe" that contains the winpe from ADK 10. (Both x86 and amd64) + wimboot and boot.ipxe

The content of boot.ipxe is the following:


cpuid --ext 29 && set arch amd64 || set arch x86
kernel wimboot
initrd ${arch}/media/Boot/BCD BCD
initrd ${arch}/media/Boot/boot.sdi boot.sdi
initrd ${arch}/media/sources/boot.wim boot.wim

(All paths are correct)

The WinPe is standard PE from ADK, no modifications.

(I've been following this guide: to the letter)

Now, when I boot from the ISO that can be downloaded, I can run DHCP o get and IP and subnetmask, no gw since it's on the same subnet and the DNS is set to the correct IP.

Now, when I run the following command:
chain I get the following error:
"No such file or directory ("

I can' for my life figure out why I get this... If I run a nslookup on my server it resolves to the correct IP so the DNS is working and all the files are in the correct folders....

Everything is run in Hyper-V on my Windows 10 laptop. Clients are Generation 1 and I'v tried both with the standard adapter and the legacy adapter. Both the client and the server is connected to an own private switch, so there is no traffic interfering.

Does somebody have any ideas?

Best regards
Find all posts by this user
Quote this message in a reply
2015-11-21, 20:51
Post: #2
RE: No such file or Directory (2d0c613b)
(2015-11-10 13:21)Wildfire3 Wrote:  chain I get the following error:
"No such file or directory ("

As it says on that page: "Error: HTTP 404 Not Found" your server returns with 404, If you are certain this file exists and everything is ok, and it works from an browser etc, your next step is to sniff the network with something like tcpdump or wireshark to see what the server recives and what it sends out.
Remember that IIS returns 404 (if i'm not mistaken) when the fileending is not configured, you could try to rename the script to .txt and test if there is any change.

Use GitHub Discussions
VRAM bin
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 2 Guest(s)