Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
wimboot hangs at an Asus MB
2015-11-11, 13:14
Post: #1
wimboot hangs at an Asus MB

I've encountered wimboot hangs on the Asus Z11-A motherboard. My script is:

initrd x86/BCD BCD
initrd x86/boot.sdi boot.sdi
initrd x86/boot-win7-2k8-x86-2014.11.26.wim boot.wim
chain wimboot/wimboot-2.5.1

All files are downloaded from http. All files finishes to download, but as soon wimboot is started, no output of the line with wimboot version and on the screen randomly appears some symbols, or computer starts to beep, and computer hangs. Only reset can be pressed.

I've tried using singed and unsigned version. An older version. All behaves the same. On other MBs which I could test - this works. Also it works in vbox.

I've tried to only download BCD and start wimboot pause. wimboot printed its version, showed some info and waited for keypress. If I press it immediatly - an error is shown that bootmgr.exe not found and computer restarts. If I do not press a key for a longer time - computer hangs.

If first is downloaded the wim file and wimboot is started - again no version is shown by wimboot and computer hangs.

Downloading BCD and boot.sdi and issue wimboot pause, shows version, some info and computer hangs.

I've tried to use stock undionly.exe - same effect. So its not because of my building from sources.

Inserting imgstat before wimboot - shows info about all downloaded files and again no wimboot version is shown and computer hangs.

So there is some bug with this motherboard and wimboot. I can notice that this motherboard behaves bad also with a Transcend SSD disk. Sometimes disk dissapear even in BIOS.

Hope to solve the problem as we have about 50 such computers.
Find all posts by this user
Quote this message in a reply
2015-11-19, 14:24
Post: #2
RE: wimboot hangs at an Asus MB
Found another netbook with the same problem. Its Acer Extensa 250B series EX2508-C1KY.

I've tried to skip chaining to pxelinux.0. So ipxe loads files, loads and starts wimboot. And is working ok.

Somehow on some computers wimboot does not interact correct with pxelinux.0, even `imgfree pxelinux.0` is supplied.
Find all posts by this user
Quote this message in a reply
2015-11-21, 20:45
Post: #3
RE: wimboot hangs at an Asus MB
Are you using pxelinux->ipxe->wimboot, or just pxelinux->wimboot ?
but it works in all these cases if you only use ipxe without first using pxelinux?

You might get some more info from compling wimboot with debug enabled. But we do know from before that one some bios configs pxelinux->wimboot or even pxelinux->ipxe causes issues, often because of buggy bios or PXE firmware.

Since you have several machines showing this it should not be an memory error, but an proper long-running memtest shouldn't hurt.

Use GitHub Discussions
VRAM bin
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 1 Guest(s)